Netlify Custom Domains, DNS & SSL are setup but domain doesn't work


I recently deployed a new blog using Hugo through netlify, it works using the netlify domain

But my custom domain is not working.

Here are my DNS configs in CloudFlare.


Surprisingly, I have the same setup for a different and it was working fine. It also stopped working from last week.

Kindly help me on this!

i think it just needed a little time.

here is what i see:

Interesting, It works on my mobile, but not on my laptop. I have cleared all cookies, history etc. Tried in various browsers Firefox, Chrome, Safari.

Any advice?

Usually, that pattern has to do with either a firewall or a configuration setting on your router (i.e., IPv6 only). You could also ask a few other people whether they’re able to access it from their networks- to echo Perry (we’re on different networks), your site is showing up for me.

Yeah, I tried with various other networks on my laptop. It doesn’t work. whereas it works in my mobile as mentioned before.

hi again, unfortunately we’re not able to offer more help on this - if the site loads on your phone, it is either an issue with your laptop or with the networks that you are connecting to with your laptop. Sorry we don’t have better news!