Netlify CMS login page at /admin seems to be indexed by Google

Hey everyone! Just found out that Google has indexed my admin page:

I am pretty sure I have the most default setup out there. There are no clickable links leading to my admin page anywhere on the site.

I wonder if anyone else has noticed this, and if there’s a preferred way to prevent Google from indexing the page.

Thanks!

There are multiple:

You can use robots.txt or use the noidex tag in the <head> or even send the noindex response headers.

@hrishikesh Can I suggest that the code for the admin file at Add to Your Site | Netlify CMS | Open-Source Content Management System be changed to include the <meta name="robots" content="noindex"> tag please as most people setting this up for the first time will not think of adding that and there really should not be a use case for having this indexed in any search engine!