Netlify cms collection path option not working past two days on the live site

I am unable to create new content in the cms. Works fine on my local stack but when it is live on netlify, I cannot not load the new content pages for any of my collections. It seems to be related to the path option for the collection. Removing it, makes it work again. I am using hugo and I must have the path option. Why has this stopped working. It was perfectly fine only few days ago.

name: "authors",
label: "Authors",
label_singular: "Author",
folder: "site/content/authors",
path: "{{slug}}/_index",
sortable_fields: [ 'title' ],
create: true,
editor: {
preview: false
fields: [
{ label: "Title", name: "title", widget: "string" },
{ label: "Occupation", name: "occupation", widget: "string" },
{ label: "Summary", name: "Summary", widget: "string", required: false },
label: "Profile Image",
name: "image",
widget: "image",
required: false,
media_folder: "/site/static/uploads",
public_folder: "/uploads"
{ label: "Body", name: "body", widget: "markdown", required: false }

Console error is the following:

netlify-cms-app.js:formatted:27459 Uncaught (in promise) TypeError: Cannot read property 'filter' of undefined
at listFiles (netlify-cms-app.js:formatted:27459)
at async Promise.all (index 0)
at async K.processEntry (netlify-cms-app.js:formatted:15470)
at async netlify-cms-app.js:formatted:16091


The better the post - the faster the answer.

Try adding an extension maybe?

path: "{{slug}}/"

yes, pretty much tried everything possible. As said, I get no errors on my local stack. It works just fine there. Live, not so much luck.

Also one thing it does not do locally, giving me an error when collection is empty. Perhaps that can help to find out what the heck is going.

error: "Failed to load entries"
meta: {collection: "whitepapers"}
payload: "TypeError: Cannot read property 'filter' of undefined"

Any collection that does not use path or is a file collection, works perfectly fine.

Actually I might found the issue. PWA initialization seems to cause the issue for some reason. After removing the registration, it worked again. I have no idea why, specifically the path option seems to be effected by it.