Home
Support Forums

Netlify CLI not serving app at :8888

Hi,

I’m running Netlify dev locally to test a react app with a handful of Netlify functions. Running netlify dev starts up the app itself correctly (at default port 3000) and the functions server (at a random port), but the combined Netlify dev server doesn’t respond (defaulted at 8888, or specified with the port flag). There are no obvious errors from the CLI, and I’ve tried removing the global package and reinstalling it.

Any advice much appreciated – thanks!

Hi @nofurtherinformation,

Could you paste the contents from shell that you get after running netlify dev?

Sure - here’s what I’ve got:

(base) dh@Dylans-MacB

% netlify dev

◈ Netlify Dev ◈

◈ Ignored **netlify.toml file** env var: NODE_VERSION (defined in .env file)

◈ Ignored **build settings** env var: NODE_VERSION (defined in .env file)

◈ Injected .env file env var: NODE_VERSION

◈ Injected netlify.toml file env var: AWS_LAMBDA_JS_RUNTIME

◈ Ignored **build settings** env var: project_id (defined in .env file)

◈ Injected .env file env var: project_id

◈ Ignored **build settings** env var: SK_ID (defined in .env file)

◈ Injected .env file env var: SK_ID

◈ Injected build settings env var: CI

◈ Ignored **build settings** env var: CLIENT_EMAIL (defined in .env file)

◈ Injected .env file env var: CLIENT_EMAIL

◈ Ignored **build settings** env var: CLIENT_ID (defined in .env file)

◈ Injected .env file env var: CLIENT_ID

◈ Ignored **build settings** env var: REACT_APP_EMAIL_FORM_URL (defined in .env file)

◈ Injected .env file env var: REACT_APP_EMAIL_FORM_URL

◈ Ignored **build settings** env var: SK (defined in .env file)

◈ Injected .env file env var: SK

◈ Ignored **build settings** env var: client_x509_cert_url (defined in .env file)

◈ Injected .env file env var: client_x509_cert_url

◈ Ignored ***general context*** env var: LANG (defined in process)

◈ Loaded function _query.

◈ Loaded function bigquery.

◈ Loaded function cors.

◈ Loaded function countyMoran.

◈ Loaded function gzip.

◈ Loaded function michiganQuery.

◈ Loaded function q.

◈ Loaded function qTimeseries.

◈ Loaded function query.

◈ Functions server is listening on 61990

◈ Starting Netlify Dev with Create React App

ℹ 「wds」: Project is running at http://192.168.1.11/

ℹ 「wds」: webpack output is served from

ℹ 「wds」: Content not from webpack is served from /Users/dh/Documents/GitHub/covid/public

ℹ 「wds」: 404s will fallback to /

Starting the development server...

Compiled with warnings.

src/components/MapButtons.js

Line 130:17: Using target="_blank" without rel="noreferrer" (which implies rel="noopener") is a security risk in older browsers: see https://mathiasbynens.github.io/rel-noopener/#recommendations react/jsx-no-target-blank

Line 131:17: Using target="_blank" without rel="noreferrer" (which implies rel="noopener") is a security risk in older browsers: see https://mathiasbynens.github.io/rel-noopener/#recommendations react/jsx-no-target-blank

Line 132:17: Using target="_blank" without rel="noreferrer" (which implies rel="noopener") is a security risk in older browsers: see https://mathiasbynens.github.io/rel-noopener/#recommendations react/jsx-no-target-blank

src/components/TopPanel.js

Line 134:11: 'shouldSaveVariable' is assigned a value but never used no-unused-vars

src/hooks/useLoadData.js

Line 15:10: 'files' is defined but never used no-unused-vars

Line 237:9: 'tablePromises' is assigned a value but never used no-unused-vars

Line 238:9: 'queriesToExecute' is assigned a value but never used no-unused-vars

Line 239:9: 'tableNames' is assigned a value but never used no-unused-vars

Search for the keywords to learn more about each warning.

To ignore, add // eslint-disable-next-line to the line before.

Looks like Netlify Dev never started?

Are you using Node 17 locally by any chance?

I had seen this happen recently when using Vite:

Hi Hrishikesh – good call! Swapped down to v14.xx and all good now :pray:

Thank you!