Home
Support Forums

Netlify Can not find the Manifest.json

Hi,

I have converted my Webflow site using udesly adapter and now, want to add manifest.json and Service-worker.js to the root folder of my website. But for some reasons, these files are not shown!

Since It’s using Eleventy, do you think I’m doing something wrong?

Hi there, glad you found us :wave: before we can help you, we need a little more information on the issues you are facing.

Please tell us:

  • the name of your build instance: “example-jones.netlify.com
  • your repo
  • what you have already tried doing to resolve this issue
  • any error messages you have received in your terminal window or in the developer console

Hello there!

I’m trying to convert it into a PWA site. I use the normal method by adding manifest.json and service-wroker.js to the root folder and index.html file but for some reasons, it doesn’t work here!

Do you know any solutions? I need it because I want to launch it as soon as possible.

Hi @mojahani

You have the files in your project root which is not the publish directory (according to the netlify.toml it is publish = "public".) The service worker and manifest are static assets that don’t require building, so perhaps putting them in the static directory will help (this is where other assets like CSS are.) Assuming they are referenced in your HTML they should load.

Notice your canonical URL is wrong though

And you have a few errors

Is this the same site you were having issues with in Netlify problem (Problem writing Eleventy) ?

1 Like

I have a question. I must add the codes to the index.html file? The path would be something like this?

/static/.json - /static/.js?

For the second problem that I have reported a few hours ago, I found a solution. the .eleventy.js was missed from the root folder.

The Manifest works now! but service-worker.js is not available.

`<script> if ("serviceWorker" in navigator) {
    // register service worker
    navigator.serviceWorker.register("/static/service-worker.js");
  }</script>`

Correct, service worker is still missing.

Was unable to find masnifest.json either.

Have you tried downloading the deployed site to see if these files are deployed and where they are? In the Netlify UI select your Site then Deploys, your Published deploy then the download icon

I have checked. I also downloaded and added the service-worker.js to the root folder since Netlify will change the structure of the website folder, compared to what I have uploaded on Github.

It’s still not available.

That’s because Netlify runs the build command in your package.json (which is npx @11ty/eleventy.) The output of this is your website.

As suggested previously, put them in the static directory.

I downloaded your code, put the manifest.json and service-worker.js into the static directory then npm run build and that’s that’s where they are in the built site /static/<file>.

2 Likes

It shows me an error when I try to build the Github folder.

can you post a screenshot of the error, please?

1 Like

[quote=“mojahani, post:11, topic:41209”]

I found out what I was doing wrong! @coelmay Thank you so much for your help :pray:

2 Likes

So glad you found a solution here. @coelmay, thanks for doing some awesome problem solving :netliconfetti:

2 Likes