Net::err_cert_common_name_invalid

Hello everybody,

I setup a new domain, it works except https gives NET::ERR_CERT_COMMON_NAME_INVALID

Is this something I can solve by myself or should I wait for netlify to intervene ?
It’s not a custom certificate it’s letsencrypt setup by netlify.

Thanks.

Hi, Laura,

thanks, it’s solved as I did ask support in //.

For others, I learned I did this stupid thing :slight_smile:

“repeatedly press a “refresh certificate” button would be worse as you’d likely get locked out of getting a certificate for a week”

1 Like

Hey @laura
I’m hoping you can help me.
I’m getting this when trying to see my site www.javisanchezplanelles.com (I bought my domain from elsewhere)


I do have HTTPS enabled as I can see on my dashboard and I tried to renew it but still getting the error.
I have 2 DNS records, don’t know if that helps.
Thanks a lot!!

UPDATE: I did renew the certificate and then it worked perfectly.

1 Like

Hi, I completed the setup for a new domain (edstechsupport.com), pointed the name servers to Netlify, and I expected the site to show as normal. But I get this error:
NET::ERR_CERT_COMMON_NAME_INVALID

The certificate still shows my old host provider:
Issued to *.hostgator.com
Issued by: Sectigo RSA Domain Validation Secure Server CA

So I tried these things:
1) Performed ‘Clear SSL state’ on my Win10 PC
2) Verified no SSL records were at my old hosting provider HostGator
3) Performed Let’s Encrypt “Renew certificate” at Netlify site settings

I still get the error. What do you think?

hi there! looks like it just needed some time.

Thanks for checking! It’s working now :slight_smile: