Name is already taken, is conflicting the ownership with other existing zones

While trying to add a domain i own (registered with another registrar), i get the error “name is already taken, is conflicting the ownership with other existing zones”. I am quite sure that i don’t have any other netlify account where i have added this domain. I am also creating this topic so that i can link to it to verify my domain ownership by creating a TXT record with the name:verified-for-netlify and value linking to this post, as per your support guide here

@rushilshakya Welcome to the Netlify community.

This is odd. I’m not seeing any connection between your custom domain and Netlify. You still do have your custom domain forwarding to your Medium account, of course.

Have you tried creating A and CNAME records with Dreamhost to point your domain at Netlify?

No - i was trying to point to Netlify’s Name servers. Is there any way you can fix this error? if not, then i will go the A and CNAME route

@rushilshakya It depends on how you were trying to do the “pointing.” Typically, you don’t point at the Netlify name servers, you delegate all DNS duties to them from your registrar, so that all of your DNS entries will be on Netlify.

Yes - i was trying to delegate all DNS duties to Netlify name servers - i have done it with a few other domain names and it has always worked with Netlify. this one… is giving me the name is already taken error

Hi, @rushilshakya. That domain was already to a different Netlify team. We can remove it from the other team if you make a verification DNS record. There is a support guide with more information about this here:

​Please let us know if you create the verification record or if there are any questions.

Done. i have created a TXT record with Name: verified-for-netlify. The value is the URL to this post:

Hi, @rushilshakya. Sorry it took so long to get a reply here.

The DNS zone has been removed from the other team and you will be able to add this custom domain to your team or site now.

If you still get any errors or if there any questions, please let us know.

Thanks - it is working now.

1 Like