Naked domain NOT redirecting to www

Hi,

I have a custom domain (from Namecheap) and have set it up to use Netlify’s DNS by adding the 4 nameservers to the Namecheap DNS control panel.

Everything is working apart from the naked domain is not automatically redirecting to the www subdomain. From what I can tell, this is supposed to ‘just work’.

I haven’t changed any of the default DNS records that Netlify sets, and I can see records in there for www and non-www domains.

I have also added IP6 hoping that might help, but with no luck.

Any ideas?

Thanks,

Matt

You need to tell Netlify to redirect the root domain to the subdomain, if you havn’t already done so. For the few sites I have with Netlify so far, none of them has redirected automatically without clicking the “Redirect to primary domain” link.

You can do so under “Settings -> Domain Management -> Domains”.

In the Domain Management > Domains section I already have a setting for this.

It looks something like this -

www.my-domain.com
Primary domain

my-domain.com
Redirects automatically to primary domain

In the actual DNS records section I have 2 records that look like this -

my-domain.com 3600 IN NETLIFY
www.my-domain.com 3600 IN NETLIFY

Not sure what else I can try?

1 Like

Just to be clear, if I go here in the browser it works:
www.my-domain.com

However if I go here:
my-domain.com
I get a “Your connection is not private” error (NET::ERR_CERT_COMMON_NAME_INVALID)

If you go to “Settings -> Domain Management -> HTTPS”. Does it say that the SSL certificate is issued for both the root domain and the subdomain?

Have you tried to ping the root domain, aka, example.com from your computer to see if it might be cached and is still redirecting you to an old IP?

If you visited the domain before changing to Netlify, it is possible that your computer or ISP is caching the old results, and is still pointing you to the wrong server. As in, not Netlify. This is usually solved by itself whenever the TTL expires and DNS refreshes. You can figure out if cache is at work by doing a traceroute and or ping from your computer.

Another simple test is merely visiting the domain from a computer / phone that has never visited the site before. Preferably with an ISP that hasn’t done the same.

@mattbadley I see your site’s SSL certificate was updated by our system about 7 hours ago. Are things as expected now?

Yes - it’s all magically fixed itself now so must have been the SSL cert.

Thanks for all your help!

1 Like

My nake domain has also stop working nupebaze.com.ng till i use www.nupebaze.com.ng
Please who know how to fix this?

Hi, @Aliyusidi, and welcome to our Netlify community site. :slight_smile:

There are two ways to point a custom domain to Netlify:

At this time, I don’t show either being used:

nupebaze.com.ng.	    21600	IN	NS  	ns2.qservers.net.
nupebaze.com.ng.	    21600	IN	NS  	ns1.qservers.net.
www.nupebaze.com.ng.	14400	IN  CNAME 	ghs.google.com.
  • Also, there was no A or AAAA record for nupebaze.com.ng when I tested.

If you wanted to use external DNS and the Netlify site was example.netlify.com, the DNS record recommended are:

www.nupebaze.com.ng.	3600	IN  CNAME 	example.netlify.com.
nupebaze.com.ng	    	3600  	IN	A       104.198.14.52

Would you please try creating those DNS records with your current DNS service and let us know if that works or not?

Thanks @Luke i will try and reset it.

1 Like