My site is deployed but I'm getting "page not found"

I’ve deployed my site but I’m still getting "page not found."

I deployed from the command line and I did check out the support guide for this type of issue.
However, I was unable to find an answer as I’m seeing an index.html when I check the details of my deploy.

What could be the problem that I’m experiencing? I’m having trouble diagnosing as my index.html is present.

Here are my build settings:

Here is my deploy log:

7:19:09 PM: Creating deploy upload records
7:19:09 PM: Starting post processing
7:19:09 PM: Post processing - HTML
7:19:09 PM: Post processing - header rules
7:19:09 PM: Post processing - redirect rules
7:19:09 PM: Post processing done
7:19:09 PM: Site is live ✨

Thank you in advance for your help. :pray:

I think this is the same repo you’ve used in some other thread in which you say the website is not building. Here’s the thread: Error: html-webpack-plugin could not minify the generated output. I t tried the repo and the error is still present. Without the error being fixed, the website will not work.

@blakelucey If your index.html file is at the top level of your site, it will load. Where is your index.html file in your file hierarchy?

Hi, @blakelucey. It looks like you fixed it now.

Please feel free to share your solution here as I’m sure others would find the information useful.