Home
Support Forums

My Site can only be reached on Firefox (or by using data on my phone)

Hello,
I deployed my portfolio created with React by dragging and dropping the build (npm run build) folder onto netlify (I believe it’s called manually deployed).

However I recieve the message:
This site can’t be reached
mounirelabbas.com unexpectedly closed the connection.

My knowledge is very limited on the subject but here’s what I’ve found.
After deploying, I refreshed the website on my phone occasionally for 2 days and kept recieving “This site can’t be reached” - until this morning, I opened chrome at the gym and it loaded… When I got back home, doesn’t work again.
So, I disconnect my phone from my home wifi and browse to the website using data, and it works.
I get on my PC, It doesn’t load on chrome or edge, but it does work on firefox.

-I am using a custom domain from GoDaddy.
-I used npx-create-react-app
-The site is not finished, pardon it’s appearance.

If you need any additional info please let me know, Thank you

Hi @MounirEl-Abbas

I see mounirelabbas.com is using Netlify DNS and from what I can see is correctly configured.

I have successfully loaded your site on computer and phone using multiple browsers. As you are able to load the site using some devices in some locations, this is not anything to do with the configuration of DNS for mounirelabbas.com, the setting up of it as a custom domain, or Netlify (the platform), rather more likely computer/network-specific issues in resolving the route to the site.

Have you tried the non-working browsers (Chrome and Edge) using incognito windows? Sometimes this will load a site when there is local caching of an old site or DNS lookup. This article explains how to clear DNS cache on Windows and macOS. It is possible to clear the internal DNS of individual browsers also (though not necessarily required if doing system-level DNS cache clearing):

  • Chrome chrome://net-internals/#dns
  • Edge edge://net-internals/#dns
  • Opera opera://net-internals/#dns
  • Firefox about:networking#dns

Thank you for your reply,
I just finished trying all the above, then restarted my pc, phone, and tried again. Only firefox seems to work. It must be like a network security-type deal but I don’t know where to find those settings let alone navigate them.
Anything else you recommend that I should try?

Network issue yes, security-type issue no.

You could try restarting modem/router, but short of that, I cannot offer any more advice.

Very well, thank you for your time

I think Coel is right - you should be trying to debug your home network connection, asking a friend if they can see the site, etc :slight_smile: I can see it just fine from my PC, using chrome, which lends credence to Coel’s suggestion (which is also what I would have said, after providing similar advice to folks for the past 5 years in this job :))

Hmm, well it’s good to know the problem is only on my end and others can open it. I will finish the project then debug it on my side. Thank you very much

Just an update, I havent done anything, however it actually works now. Thank you both for your help, have a good day.

1 Like