My React App Could Not Be Deployed To Netlify Due To The Error Below

I’m trying to deploy my react app to netlify but I was getting this notification error below, How can I fix this?

You have a malformed package.json in your folder. This will most likely lead to a broken build when attempting to install your npm dependencies.

Here is the repo link repo link

The error indicates that your package.json is incorrect. If you share the file or the repo, someone can help you with it.

I just shared the repo link @hrishikesh

I’m assuming it’s because you have a package-lock.json in your repo. I just tried deploying your website with that file removed and it worked fine. Check it out here: GitHub - Hrishikesh-K/Button-Component-master. Website here: https://wonderful-poincare-151d90.netlify.app/

2 Likes