"[My domain name] doesn't appear to be served by Netlify"

*My Netlify site name: ‘determined-golick-ff42b1.netlify.app’

*The custom domain is youcanbeapirate.com (or www.youcanbeapirate.com). Everything has worked previously, but now, all of a sudden the site doesn’t work at all and I get this message:

**youcanbeapirate.com doesn't appear to be served by Netlify**

We can’t renew your Let’s Encrypt certificate automatically until the issue is resolved.

I’ve checked the troubleshooting guide and so far I’ve only managed to delete the DNS records (below is what they looked like):


So, I’m still not sure what even is the problem, let alone the answer. Please help!

Best regards,

Hi @AnttiRask,

Welcome to the Netlify Support Forums and thanks for reaching out!

Reviewing your site’s Netlify DNS settings, I see that the NETLIFY Records have been removed. The quickest and easiest way to add them back is to remove the custom domains from here (by clicking Options then remove domain) and then add them back in.

Let us know if you continue to have issues.

Hello, @Melvin,

And thank you for the swift reply!

I tried removing the custom domains. I then added them back in, but the first thing I faced after verifying the custom domain was this message:

**youcanbeapirate.com** is already registered. If you registered this domain name through a different registrar, select **Add domain** to begin delegating it to Netlify.

So my options are slim. ‘Add domain’ doesn’t work as it leads to the same situation I was in before (" www.youcanbeapirate.com doesn’t appear to be served by Netlify"). And ‘Try another’ isn’t obviously going to work either.

So, any ideas what can/should try next?


Best regards,

:wave: @AnttiRask , thanks for your patience!

Our developers rolled out a bug fix that should address this issue. Would you be able to try removing and adding the custom domains again and let us know if you still see the error message?

Thank you for your continued help with troubleshooting!

I have exactly same issue and tried everything from the troubleshooting guides .

Hey @AnttiRask,

Apologies for the previous comment. This bug has been fixed for newer customers who’ll be facing this issue. As for you, we’ve manually reset the domain.


Again, please do not make multiple posts.