Missing files or folders from repo, or lack of knowledge

Hi. I was working on my first site months ago. Had to stop a while for personal reasons.
Now I tried to clone my repository and start a local hugo server to continue developing, but it seems like several folders and files are missing.

I CAN run a local hugo server from my backup source (the same folder that I committed and pushed in the repository), but when I clone the site’s repository it doesn’t run.

What is very strange for me is that my site is working. How is this possible?

https://monumental-puppy-a7cdb1.netlify.app/

Admins, please, move this question post to it’s right section.
Thanks.

Hey @Tequemoflia

Are you able to share the repository you are working with?

1 Like

Sorry to respond so late.

Accidentaly I found the correct answer. I did have a lack of understending.

There’s no problem with Netlify. The problem was in my git usage, now I know:

Is absolutely required to add “–recurse-submodules …” when cloning my repository to work with themes.

Tutorials I read didn’t tell this.

Pleas mark this topic as solved.

Thank you.

Thanks for coming back and letting us know ! Glad that you found the solution. Happy building!