Home
Support Forums

"Looks like you've followed a broken link" when viewing site

My index.html file is inside public folder, whether we can’t put index.html file inide a folder?

You’ll need to set your public folder as your publish directory, and here’s why! :slight_smile:

Fine it’s working now.Very very thank you for support and assist.

1 Like

Hey, im new to deployment. trying to deploy my react website but it says :

Page Not Found

Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.

Github: https://github.com/kennymanman/school.git
Netlify: https://competent-borg-444b06.netlify.app

Hey, im new to deployment. trying to deploy my react website but it says :

Page Not Found

Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.

Github: https://github.com/kennymanman/school.git
Netlify: https://competent-borg-444b06.netlify.app

Looks like it’s working for me! I’m guessing you updated your publish directory to public?

Because you’re using React, you’ll need a SPA redirect rule which is discussed in the redirects guide (search for Single-Page Apps).

Yeah i visited the post, But i’m new to netlify and coding not sure what to do with ```
/index.html 200

Could you simplify it to me, like where to go and do. Thank you.

hey @kennymanman, you’ll need to create a file called _redirects and add that line of code to it. Place that in the root directory of your project, and redeploy. that should fix things.

Like this
github: https://github.com/kennymanman/school.git

yep, seems correct on first glance. is the issue still happening?

its still showing the error

i think you may be seeing a version of your site that is cached somewhere, as I can load it:

Can you try again from an incognito window?

have you tried clicking the pages like home, contact us

its showing the navbar but the pages are showing not found

@kennymanman,

Your _redirects is in the wrong directory. I can see from your deploy log:

No redirect rules processed

Add this file to your public directory :slight_smile:

Thank you i really appreciate the help. it worked.

1 Like

Hey, I am new to Netlify. I deployed my test site successfully but when I clicked the Upload button on index.html, got a popup saying:

Page Not Found
Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.

Netlify: https://mytestsite-jc.netlify.app/

Please help. Thanks.

Hi, @jc0bl, your site code is calling a file named savetofile.aspx which is an Active Server Page file.

There is no IIS running at Netlify so this will never work. The following support guide explains why in more detail:

If there are other questions after reading that support guide, please let us know.

Hello ,

I tried different things but no way to get the website working . always the same erros page not found …

my settings:
Repository

github.com/RaphaelPereira88/My-personal-Blog

Base directory

Not set

Build command

Not set

Publish directory

blogWebsite

Deploy log visibility

Logs are public

Builds

Active

My project is pretty simple , it’s a blog/website html css and a bit of javascript to create the sections and the second navigation bar.

I shared my files from my git hub ( see screenshots below) and they are all in the folder called
" blogWebsite. "

Could you please tell me how to get this working ?

many thanks

Screenshot from 2021-03-19 12-30-12|690x253git hub

Hi, @RaphaelPereira88. You don’t have an index.html. You have a main.html file instead.

This would make the site available under that path. So instead of this:

https://example.netlify.app/

The base page would be this:

https://example.netlify.app/main

(Replace example with your site’s actual subdomain.)

If you rename main.html to index.html that path above (/main) won’t be required anymore.