Login loads forever

Hello everyone,

I tried creating an account on Netlify with GitHub auth to deploy my static website; when I clicked signup there was a loading logo it ran for a few seconds, then disappeared and I was left on a blank white page, I waited for a minute or two and nothing happened, I thought it is just some error so I got back to the home page, which worked fine, and tried logging in but I was left with just loading logo and nothing more it ran for few minutes and I closed tab. Tried logging in through incognito, also deleted cookies, and removed authorization for Netlify on my GitHub in order to try again but nothing happened. Error persisted, researched on Google but didn’t find anyone who had a similar experience. However I successfully created and logged in to this forum account and tried logging in again after creating this account but still, the same problem persisted. Can anyone from support help me solve this problem?



Hi Stefan,

Can you please share the email you tried to signup with?


Hi did you find any solution?

Can you please try and signup/login again but you should be prompted to submit your ID verification documents or to bypass this you can signup for a Pro account.

Still the same problem, page loads forever, there is no form displayed.

Do you have a solution?

Can you give this to someone else to handle my situation?

Hi we just sent a verification email. Please check your spam if you do not receive it.


I checked email and spam and there is no verification there. Is it possible to delete my account if it’s even in your database and then I can try to open it again?

We sent the verification to the above email. You can attempt to signup again.

This is all the emails I have from Netlify, I didn’t receive any other emails. Tried signing up again but same loading page.

Hi, we cant send a verification as you don’t have an account on our platform. Can you please try and signup again?

Can’t signup, same problem. Maybe looking at the URL will give you some clue as to why is this happening.

Hi, this is very strange and I haven’t encountered this before. Can I ask what country you are trying to signup from? certain countries are not able to access our platform. Also i’m assuming you cleared your browser cache etc?

Yes I deleted cache, I am from Bosnia and Herzegovina

@vstefan22, can you try using a different device / browser / network or try using a VPN.