Locked state in custom domain setup

This is expected.

Yes.

Thanks for your prompt reply! The CNAME DNS change was made about 12h ago… so I’ll give it more time before reporting back.

Hey there! So far I’m seeing your cname record, but not an A record. If you don’t see it propagate in 48 hours let us know!

So I need an A record instead of an ALIAS Record? I am pretty sure the domain administrator only set an ALIAS. If that’s the case, I’ll ask him to make the change.

UPDATE: Adding an A record fixed it.

So, to be sure you don’t have a misconfiguration check that you’ve added both an A record with value @, which should point to 75.2.60.5, and a CNAME of your www.{your-domain}.com pointing to your {your-netlify-assigned-domain}.netlify.app domain.

To verify that you’ve done the above correctly, you can use this command in your terminal:

dig A +short @8.8.8.8 {your-domain}.com
// expected output => 75.2.60.5

dig CNAME +short @8.8.8.8 www.{your-domain}.com
// expected output => `{your-netlify-assigned-domain}.netlify.app`

If either commands return an empty output, there are two plausible reasons:

  1. Your DNS changes haven’t propagated yet
  2. You have likely badly entered the DNS records

P.S. If you don’t have the dig CLI tool, you can find how to install it here.

Technically you can use either depending on the options available. I see you’ve configured the A record and cem-group.it is now working. www.cem-group.it is not secure. Is it assigned to the same site as cem-group.it? If the SSL certificate in Netlify doesn’t cover it (which I believe it does not) try renewing the certificate.

It is assigned to the same site, so I just renewed the certificate… guess I’ll wait and see :slight_smile:

UPDATE: the www site is now served under https, too. Do you recommend setting it as a primary domain?

Interesting cause I had set an ALIAS days ago pointing to apex-loadbalancer.netlify.com, but only the A record seems to have worked

That is the recommendation per Netlify documentation.

The CNAME record for www.cem-group.it is not correct

$ dig www.cem-group.it CNAME
www.cem-group.it.	929	IN	CNAME	https://steady-paprenjak-1c5b90.netlify.app.

You need to remove the https:// from the record value so i.e.

2 Likes

Hi I am running into the same issue as @muschpusch.

williamreckziegel.netlify.app

@reckziegelwilliam, your domain is not pointing to Netlify:

dig A +short williamreckziegel.com @8.8.8.8
185.230.63.107
185.230.63.186
185.230.63.171

image
Hallo!
Same problem reported by many others: I’m stuck, I can’t set the primary domain as “www.finiper.it” because the certificate is being provisioned, and even if I confirm I want to switch, the result is alway the same error.

Is there something you can do to solve the problem?

Thanks for any help!
Dave

Hi, @Iper_Montebello_S.P. It appears this was resolved by the SSL provisioning completing today. It appears you have a paid plan type (paid plan type = anything other than the Starter plan).

As such, please feel free to open support tickets about such issues going forward as you will almost certainly receive faster responses via support ticket.