Local build is different than what's on site

It’s always deployed with what I would expect locally

but when I try to deploy it to netlify, it looks like the original repository I forked with changes to text content but none of the images I loaded are showing up…


Hi there, glad you found us :wave: before we can help you, we need a little more information on the issues you are facing.

Please tell us:

  • the name of your build instance: “example-jones.netlify.com
  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console

It would also be a good idea to confirm that the build & deploy process is actually complete - linking toa deploy log would be helpful. thanks.

Thanks, Perry.

My domain: “widschicago.org

I have already tried fixing the baseURL in the config.toml file. The main issue is with the images-- the static/img file is hosted on Github in the original repository I forked from. Should I try putting that folder with images somewhere else?

deploy log:
12:06:17 PM: Build ready to start
12:06:19 PM: build-image version: 9cade8af58c2cf3a17a1e9433d2e979149488837
12:06:19 PM: build-image tag: v3.3.5
12:06:19 PM: buildbot version: 6067c60f3bc043bb6b9ee9b57c85b10029c65bfd
12:06:19 PM: Fetching cached dependencies
12:06:19 PM: Starting to download cache of 132.6MB
12:06:21 PM: Finished downloading cache in 1.400501044s
12:06:21 PM: Starting to extract cache
12:06:25 PM: Finished extracting cache in 4.461040395s
12:06:25 PM: Finished fetching cache in 5.979039392s
12:06:25 PM: Starting to prepare the repo for build
12:06:25 PM: Preparing Git Reference refs/heads/master
12:06:26 PM: Found Netlify configuration file netlify.toml in site root
12:06:26 PM: Found Netlify configuration file(s). Overriding site configuration
12:06:26 PM: Different build command detected, going to use the one specified in the Netlify configuration file: ‘hugo’ versus ‘’ in the Netlify UI
12:06:26 PM: Starting build script
12:06:26 PM: Installing dependencies
12:06:27 PM: Started restoring cached node version
12:06:30 PM: Finished restoring cached node version
12:06:31 PM: v10.18.1 is already installed.
12:06:32 PM: Now using node v10.18.1 (npm v6.13.4)
12:06:33 PM: Attempting ruby version 2.6.2, read from environment
12:06:34 PM: Using ruby version 2.6.2
12:06:34 PM: Using PHP version 5.6
12:06:34 PM: Installing Hugo 0.46
12:06:35 PM: Hugo Static Site Generator v0.46/extended linux/amd64 BuildDate: 2018-08-01T09:11:41Z
12:06:35 PM: Started restoring cached go cache
12:06:35 PM: Finished restoring cached go cache
12:06:35 PM: unset GOOS;
12:06:35 PM: unset GOARCH;
12:06:35 PM: export GOROOT=’/opt/buildhome/.gimme/versions/go1.12.linux.amd64’;
12:06:35 PM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:${PATH}";
12:06:35 PM: go version >&2;
12:06:35 PM: export GIMME_ENV=’/opt/buildhome/.gimme/env/go1.12.linux.amd64.env’;
12:06:35 PM: go version go1.12 linux/amd64
12:06:35 PM: Installing missing commands
12:06:35 PM: Verify run directory
12:06:35 PM: Executing user command: hugo
12:06:35 PM: Building sites …
12:06:35 PM: 12:06:35 PM: |
12:06:35 PM: EN
12:06:35 PM: +
12:06:35 PM: ------------------+
12:06:35 PM: ----+
12:06:35 PM: Pages |
12:06:35 PM: 3
12:06:35 PM: Paginator pages | 0
12:06:35 PM: Non-page files | 0
12:06:35 PM: Static files
12:06:35 PM: | 74
12:06:35 PM: Processed images | 0
12:06:35 PM: Aliases | 0
12:06:35 PM: Sitemaps | 1
12:06:35 PM: Cleaned | 0
12:06:35 PM: Total in 51 ms
12:06:35 PM: Skipping functions preparation step: no functions directory set
12:06:35 PM: Caching artifacts
12:06:35 PM: Started saving pip cache
12:06:35 PM: Finished saving pip cache
12:06:35 PM: Started saving emacs cask dependencies
12:06:35 PM: Finished saving emacs cask dependencies
12:06:35 PM: Started saving maven dependencies
12:06:35 PM: Finished saving maven dependencies
12:06:35 PM: Started saving boot dependencies
12:06:35 PM: Finished saving boot dependencies
12:06:35 PM: Started saving go dependencies
12:06:35 PM: Starting post processing
12:06:35 PM: Finished saving go dependencies
12:06:35 PM: Build script success
12:06:35 PM: Starting to deploy site from ‘public’
12:06:35 PM: Creating deploy tree 12:06:35 PM: 0 new files to upload
12:06:35 PM: 0 new functions to upload
12:06:35 PM: Post processing done
12:06:36 PM: Site is live
12:06:56 PM: Finished processing build request in 36.647960375s



so, just to clarify, where are the images located?

I’m looking at the placeholders, and their path is:

so a relative path. Are you saying that the images are still being stored on github? :thinking:

Also, not sure if this is related, but there are quite a few errors in your developer console:

Sorry, I’ve tried a couple of different things.

The header-bg img (etc.) I’m trying to use is in

but it still inherits the images from hugo-satrday-theme/static/img (which I do not have access to).


Hi Perry,

I figured it out!

I am having issues deploying though. Would you mind taking look at my latest deploy?

sure thing, can you share your deplog log?

hmm, that is an error I personally haven’t seen before.
If I were you, my first step would probably be to unlink and then relink the repo you are trying to build from to netlify and see if that fixes things. Can you give that a try, or have you done that already?