Jekyll - "You don't have sufficient permissions to access Netlify CMS"

I am unable to log-in to my Netlify CMS. I get keep getting “You don’t have sufficient permissions to access Netlify CMS”.

I have identify enabled with Github gateway, and used this guide to get it up and running.

Hi @mattrb and welcome!
The way git-gateway works is by creating an access token to the GitHub repo. It looks like the generated token doesn’t have write permissions.

Things you can try:

  1. Disabling/Enabling git-gateway from Netlify site settings.
  2. Clearing browser cache (makes sure the CMS connects to the correct instance of git-gateway).
  3. Re-linking your site to the GitHub repo (and then disable/enable git-gateway) from Netlify site settings.
  4. Creating your own token on GitHub manually and supply it to git-gateway via Netlify site settings.