Home
Support Forums

Internal error during deploy

My site name is idrisproject.netlify.app

The problem I am having is during the deploy. The build seems to run fine. The problem started when I tried to change the build image from Trusty to Focal. No other changes have been made to the configuration, except that I added NETLIFY_BUILD_DEBUG to the environment to try to get more information about the issue.

What painfully obvious thing am I missing here?

6:54:51 PM: Build ready to start
6:54:53 PM: build-image version: fa439ad1ab9393b2c0d449d8d7c033927683f4b0
6:54:53 PM: build-image tag: v4.3.0
6:54:53 PM: buildbot version: e99637385725adf30662bad8cf7d70d9f3623653
6:54:53 PM: Building without cache
6:54:53 PM: Starting to prepare the repo for build
6:54:54 PM: No cached dependencies found. Cloning fresh repo
6:54:54 PM: git clone git@bitbucket.org:ssbaker/idris_project
6:55:28 PM: Preparing Git Reference refs/heads/master
6:55:32 PM: Parsing package.json dependencies
6:55:32 PM: 
❯ Initial build environment
baseRelDir: true
branch: master
context: production
cwd: /opt/build/repo
featureFlags: []
mode: buildbot
repositoryRoot: /opt/build/repo
siteId: ea4ac498-4307-444a-a9f5-f0ac4354ccde
❯ UI build settings
baseRelDir: true
build:
  command: hugo --baseURL https://www.idrisproject.com
  environment:
    - HUGO_VERSION
    - NETLIFY_BUILD_DEBUG
  publish: public
❯ Resolved build environment
branch: master
buildDir: /opt/build/repo
context: production
env: []
❯ Resolved config
build:
  command: hugo --baseURL https://www.idrisproject.com
  commandOrigin: ui
  environment:
    - HUGO_VERSION
    - NETLIFY_BUILD_DEBUG
  publish: /opt/build/repo/public
  publishOrigin: ui
6:55:32 PM: Starting build script
6:55:32 PM: Installing dependencies
6:55:32 PM: Python version set to 2.7
6:55:33 PM: Downloading and installing node v16.9.1...
6:55:33 PM: Downloading https://nodejs.org/dist/v16.9.1/node-v16.9.1-linux-x64.tar.xz...
6:55:33 PM: Computing checksum with sha256sum
6:55:34 PM: Checksums matched!
6:55:36 PM: Now using node v16.9.1 (npm v7.21.1)
6:55:37 PM: Started restoring cached build plugins
6:55:37 PM: Finished restoring cached build plugins
6:55:37 PM: Attempting ruby version 2.7.2, read from environment
6:55:38 PM: Using ruby version 2.7.2
6:55:38 PM: Using PHP version 8.0
6:55:38 PM: Installing Hugo 0.70.0
6:55:39 PM: Hugo Static Site Generator v0.70.0-7F47B99E/extended linux/amd64 BuildDate: 2020-05-06T11:26:13Z
6:55:39 PM: Started restoring cached go cache
6:55:39 PM: Finished restoring cached go cache
6:55:39 PM: go version go1.16.5 linux/amd64
6:55:39 PM: go version go1.16.5 linux/amd64
6:55:39 PM: Installing missing commands
6:55:39 PM: Verify run directory
6:55:41 PM: ​
6:55:41 PM: ────────────────────────────────────────────────────────────────
6:55:41 PM:   Netlify Build                                                 
6:55:41 PM: ────────────────────────────────────────────────────────────────
6:55:41 PM: ​
6:55:41 PM: ❯ Version
6:55:41 PM:   @netlify/build 18.10.0
6:55:41 PM: ​
6:55:41 PM: ❯ Flags
6:55:41 PM:   apiHost: api.netlify.com
6:55:41 PM:   baseRelDir: true
6:55:41 PM:   branch: master
6:55:41 PM:   buildId: 6142a3eb73bd765feca04f1c
6:55:41 PM:   buildbotServerSocket: /tmp/netlify-buildbot-socket
6:55:41 PM:   cacheDir: /opt/build/cache
6:55:41 PM:   cachedConfigPath: /tmp/netlify_config.json
6:55:41 PM:   context: production
6:55:41 PM:   cwd: /opt/build/repo
6:55:41 PM:   deployId: 6142a3eb73bd765feca04f1e
6:55:41 PM:   featureFlags:
6:55:41 PM:     - zisiEsbuildDynamicImports
6:55:41 PM:   framework: hugo
6:55:41 PM:   functionsDistDir: /tmp/zisi-6142a3eb73bd765feca04f1e
6:55:41 PM:   mode: buildbot
6:55:41 PM:   nodePath: /opt/buildhome/.nvm/versions/node/v16.9.1/bin/node
6:55:41 PM:   repositoryRoot: /opt/build/repo
6:55:41 PM:   saveConfig: true
6:55:41 PM:   sendStatus: true
6:55:41 PM:   siteId: ea4ac498-4307-444a-a9f5-f0ac4354ccde
6:55:41 PM:   statsd:
6:55:41 PM:     host: datadog-agent
6:55:41 PM:     port: 8125
6:55:41 PM:   testOpts:
6:55:41 PM:     silentLingeringProcesses: ''
6:55:41 PM: ​
6:55:41 PM: ❯ Current directory
6:55:41 PM:   /opt/build/repo
6:55:41 PM: ​
6:55:41 PM: ❯ Config file
6:55:41 PM:   No config file was defined: using default values.
6:55:41 PM: ​
6:55:41 PM: ❯ Resolved config
6:55:41 PM:   build:
6:55:41 PM:     command: hugo --baseURL https://www.idrisproject.com
6:55:41 PM:     commandOrigin: ui
6:55:41 PM:     environment:
6:55:41 PM:       - HUGO_VERSION
6:55:41 PM:       - NETLIFY_BUILD_DEBUG
6:55:41 PM:     publish: /opt/build/repo/public
6:55:41 PM:     publishOrigin: ui
6:55:41 PM: ​
6:55:41 PM: ❯ Context
6:55:41 PM:   production
6:55:41 PM: ​
6:55:41 PM: ────────────────────────────────────────────────────────────────
6:55:41 PM:   1. Build command from Netlify app                             
6:55:41 PM: ────────────────────────────────────────────────────────────────
6:55:41 PM: ​
6:55:41 PM: $ hugo --baseURL https://www.idrisproject.com
6:59:30 PM: Building sites …
6:59:30 PM:                    |  EN
6:59:30 PM: -------------------+-------
6:59:30 PM:   Pages            | 8122
6:59:30 PM:   Paginator pages  |  136
6:59:30 PM:   Non-page files   |    0
6:59:30 PM:   Static files     | 8842
6:59:30 PM:   Processed images |    0
6:59:30 PM:   Aliases          |  911
6:59:30 PM:   Sitemaps         |    1
6:59:30 PM:   Cleaned          |    0
6:59:30 PM: Total in 229306 ms
6:59:30 PM: ​
6:59:30 PM: (build.command completed in 3m 49.3s)
6:59:30 PM: ​
6:59:30 PM: ────────────────────────────────────────────────────────────────
6:59:30 PM:   2. Deploy site                                                
6:59:30 PM: ────────────────────────────────────────────────────────────────
6:59:30 PM: ​
6:59:30 PM: ​
6:59:30 PM: ❯ Uploaded config
6:59:30 PM:   No netlify.toml
6:59:30 PM: ​
6:59:30 PM: ❯ Uploaded headers
6:59:30 PM:   No headers
6:59:30 PM: ​
6:59:30 PM: ❯ Uploaded redirects
6:59:30 PM:   No redirects
6:59:30 PM: ​
6:59:30 PM: Starting to deploy site from 'public'
6:59:33 PM: Creating deploy tree asynchronously
6:59:33 PM: Creating deploy upload records
6:59:40 PM: Starting post processing
6:59:41 PM: Post processing - HTML
7:04:33 PM: ​
7:04:33 PM: ────────────────────────────────────────────────────────────────
7:04:33 PM:   Internal error during "Deploy site"                           
7:04:33 PM: ────────────────────────────────────────────────────────────────
7:04:33 PM: ​
7:04:33 PM:   Error message
7:04:33 PM:   Error: Deploy did not succeed: Failed to execute deploy: timed out while waiting to enter states [prepared, ready]
7:04:33 PM: ​
7:04:33 PM:   Error location
7:04:33 PM:   During Deploy site
7:04:33 PM:       at handleDeployError (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/plugins_core/deploy/buildbot_client.js:89:18)
7:04:33 PM:       at deploySiteWithBuildbotClient (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/plugins_core/deploy/buildbot_client.js:70:12)
7:04:33 PM:       at processTicksAndRejections (internal/process/task_queues.js:97:5)
7:04:33 PM:       at async coreCommand (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/plugins_core/deploy/index.js:45:5)
7:04:33 PM:       at async fireCoreCommand (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/commands/core_command.js:41:9)
7:04:33 PM:       at async tFireCommand (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/time/main.js:22:59)
7:04:33 PM:       at async runCommand (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/commands/run_command.js:89:7)
7:04:33 PM:       at async pReduce.index (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/commands/run_commands.js:92:11)
7:04:33 PM:       at async runCommands (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/commands/run_commands.js:52:7)
7:04:33 PM:       at async runBuild (/opt/buildhome/.netlify-build-nvm/versions/node/v12.22.6/lib/node_modules/@netlify/build/src/core/main.js:605:7)
7:04:33 PM: ​
7:04:33 PM:   Resolved config
7:04:33 PM:   build:
7:04:33 PM:     command: hugo --baseURL https://www.idrisproject.com
7:04:33 PM:     commandOrigin: ui
7:04:33 PM:     environment:
7:04:33 PM:       - HUGO_VERSION
7:04:33 PM:       - NETLIFY_BUILD_DEBUG
7:04:33 PM:     publish: /opt/build/repo/public
7:04:33 PM:     publishOrigin: ui
7:04:34 PM: Caching artifacts
7:04:34 PM: Started saving build plugins
7:04:34 PM: Finished saving build plugins
7:04:34 PM: Started saving pip cache
7:04:34 PM: Finished saving pip cache
7:04:34 PM: Started saving emacs cask dependencies
7:04:34 PM: Finished saving emacs cask dependencies
7:04:34 PM: Started saving maven dependencies
7:04:34 PM: Finished saving maven dependencies
7:04:34 PM: Started saving boot dependencies
7:04:34 PM: Finished saving boot dependencies
7:04:34 PM: Started saving rust rustup cache
7:04:34 PM: Finished saving rust rustup cache
7:04:34 PM: Started saving go dependencies
7:04:34 PM: Finished saving go dependencies
7:04:36 PM: Build failed due to an internal system error: Build script returned non-zero exit code: 4
7:04:36 PM: Creating deploy upload records
7:04:36 PM: Failing build: Failed to build site
7:04:36 PM: Failed during stage 'building site': Build script returned non-zero exit code: 4
7:04:36 PM: Finished processing build request in 9m43.108276901s

Hi @tektsu,

I’ve bumped the pre-process timeout for your website to 15 minutes (it’s 5 mins by default). Would you give this a try now?

1 Like

That fixed it. Thanks!