Initial commit deployed instead of current master branch

Hi, I want to deploy my current master branch:

instead, netlify deploys my initial commit 7dfa2fd3bf:

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name. Example: https://pedantic-spence-e06230.netlify.app/
  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
  • Build problems? Link or paste the FULL build log & build settings screenshot

3:20:29 PM: Build ready to start

3:20:30 PM: build-image version: 53b83b6bede2920f236b25b6f5a95334320dc849

3:20:30 PM: build-image tag: v3.6.0

3:20:30 PM: buildbot version: 8ae026ef4905d9174e416775c6b64aa19950569b

3:20:31 PM: Fetching cached dependencies

3:20:31 PM: Failed to fetch cache, continuing with build

3:20:31 PM: Starting to prepare the repo for build

3:20:31 PM: No cached dependencies found. Cloning fresh repo

3:20:31 PM: git clone https://github.com/mostafachatillon/platform_chinghub

3:20:32 PM: Preparing Git Reference refs/heads/master

3:20:33 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: ‘public’ versus ‘public/’ in the Netlify UI

3:20:33 PM: Starting build script

3:20:33 PM: Installing dependencies

3:20:33 PM: Python version set to 2.7

3:20:34 PM: v12.18.0 is already installed.

3:20:35 PM: Now using node v12.18.0 (npm v6.14.4)

3:20:35 PM: Started restoring cached build plugins

3:20:35 PM: Finished restoring cached build plugins

3:20:35 PM: Attempting ruby version 2.7.1, read from environment

3:20:36 PM: Using ruby version 2.7.1

3:20:36 PM: Using PHP version 5.6

3:20:36 PM: Started restoring cached node modules

3:20:36 PM: Finished restoring cached node modules

3:20:37 PM: Installing NPM modules using NPM version 6.14.4

3:21:31 PM: > sharp@0.25.2 install /opt/build/repo/node_modules/sharp

3:21:31 PM: > (node install/libvips && node install/dll-copy && prebuild-install --runtime=napi) || (node-gyp rebuild && node install/dll-copy)

3:21:33 PM: info sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.9.1/libvips-8.9.1-linux-x64.tar.gz

3:21:34 PM: > husky@4.2.5 install /opt/build/repo/node_modules/husky

3:21:34 PM: > node husky install

3:21:35 PM: husky > Setting up git hooks

3:21:35 PM: CI detected, skipping Git hooks installation.

3:21:35 PM: husky > Done

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/bmp/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/core/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/custom/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/gif/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/jpeg/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-blit/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-blur/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-circle/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:35 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-color/node_modules/core-js

3:21:35 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-contain/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-cover/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-crop/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-displace/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-dither/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-fisheye/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-flip/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-gaussian/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-invert/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-mask/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-normalize/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-print/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:36 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-resize/node_modules/core-js

3:21:36 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-rotate/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-scale/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-shadow/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-threshold/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugins/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/png/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/tiff/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/types/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/utils/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:37 PM: > core-js@2.6.11 postinstall /opt/build/repo/node_modules/core-js

3:21:37 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:38 PM: > core-js-pure@3.6.5 postinstall /opt/build/repo/node_modules/core-js-pure

3:21:38 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:38 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/jimp/node_modules/core-js

3:21:38 PM: > node -e “try{require(’./postinstall’)}catch(e){}”

3:21:39 PM: > gatsby-telemetry@1.3.8 postinstall /opt/build/repo/node_modules/gatsby-telemetry

3:21:39 PM: > node src/postinstall.js || true

3:21:39 PM: > cwebp-bin@5.1.0 postinstall /opt/build/repo/node_modules/cwebp-bin

3:21:39 PM: > node lib/install.js

3:21:40 PM: :heavy_check_mark: cwebp pre-build test passed successfully

3:21:40 PM: > mozjpeg@6.0.1 postinstall /opt/build/repo/node_modules/mozjpeg

3:21:40 PM: > node lib/install.js

3:21:40 PM: :heavy_check_mark: mozjpeg pre-build test passed successfully

3:21:40 PM: > pngquant-bin@5.0.2 postinstall /opt/build/repo/node_modules/pngquant-bin

3:21:40 PM: > node lib/install.js

3:21:40 PM: :heavy_check_mark: pngquant pre-build test passed successfully

3:21:40 PM: > gatsby-cli@2.12.29 postinstall /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli

3:21:40 PM: > node scripts/postinstall.js

3:21:41 PM: > gatsby@2.20.29 postinstall /opt/build/repo/node_modules/gatsby

3:21:41 PM: > node scripts/postinstall.js

3:21:41 PM: > husky@4.2.5 postinstall /opt/build/repo/node_modules/husky

3:21:41 PM: > opencollective-postinstall || exit 0

3:21:44 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/watchpack/node_modules/fsevents):

3:21:44 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

3:21:44 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fsevents):

3:21:44 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

3:21:44 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/jest-haste-map/node_modules/fsevents):

3:21:44 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

3:21:44 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/gatsby-page-utils/node_modules/fsevents):

3:21:44 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

3:21:44 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/chokidar/node_modules/fsevents):

3:21:44 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

3:21:44 PM: added 3032 packages from 1462 contributors and audited 3053 packages in 66.857s

3:21:47 PM: 159 packages are looking for funding

3:21:47 PM: run npm fund for details

3:21:47 PM: found 6009 vulnerabilities (5969 low, 40 high)

3:21:47 PM: run npm audit fix to fix them, or npm audit for details

3:21:47 PM: NPM modules installed

3:21:47 PM: Started restoring cached go cache

3:21:47 PM: Finished restoring cached go cache

3:21:47 PM: go version go1.14.4 linux/amd64

3:21:47 PM: go version go1.14.4 linux/amd64

3:21:47 PM: Installing missing commands

3:21:47 PM: Verify run directory

3:21:49 PM: ​

3:21:49 PM: ────────────────────────────────────────────────────────────────

3:21:49 PM: Netlify Build

3:21:49 PM: ────────────────────────────────────────────────────────────────

3:21:49 PM: ​

3:21:49 PM: ❯ Version

3:21:49 PM: @netlify/build 8.0.0

3:21:49 PM: ​

3:21:49 PM: ❯ Flags

3:21:49 PM: deployId: 5fdf4f9d2386054d127907e2

3:21:49 PM: mode: buildbot

3:21:49 PM: ​

3:21:49 PM: ❯ Current directory

3:21:49 PM: /opt/build/repo

3:21:49 PM: ​

3:21:49 PM: ❯ Config file

3:21:49 PM: No config file was defined: using default values.

3:21:49 PM: ​

3:21:49 PM: ❯ Context

3:21:49 PM: production

3:21:49 PM: ​

3:21:49 PM: ────────────────────────────────────────────────────────────────

3:21:49 PM: 1. Build command from Netlify app

3:21:49 PM: ────────────────────────────────────────────────────────────────

3:21:49 PM: ​

3:21:49 PM: $ npm run build

3:21:49 PM: > pub@1.0.6 build /opt/build/repo

3:21:49 PM: > gatsby build --prefix-paths

3:21:51 PM: success open and validate gatsby-configs - 0.076s

3:21:53 PM: success load plugins - 1.418s

3:21:53 PM: success onPreInit - 0.019s

3:21:53 PM: success delete html and css files from previous builds - 0.011s

3:21:53 PM: success initialize cache - 0.007s

3:21:53 PM: success copy gatsby files - 0.044s

3:21:53 PM: success onPreBootstrap - 0.008s

3:21:53 PM: success createSchemaCustomization - 0.035s

3:21:53 PM: success source and transform nodes - 0.230s

3:21:53 PM: success building schema - 0.441s

3:21:54 PM: success createPages - 0.058s

3:21:54 PM: success createPagesStatefully - 0.176s

3:21:54 PM: success onPreExtractQueries - 0.000s

3:21:54 PM: success update schema - 0.031s

3:21:54 PM: success extract queries from components - 0.586s

3:21:54 PM: success write out requires - 0.005s

3:21:54 PM: success write out redirect data - 0.001s

3:21:54 PM: warning The icon(src/images/logo.png) you provided to ‘gatsby-plugin-manifest’ is not square.

3:21:54 PM: The icons we generate will be square and for the best results we recommend you provide a square icon.

3:21:55 PM: success Build manifest and related icons - 0.179s

3:21:55 PM: success onPostBootstrap - 0.181s

3:21:55 PM: ⠀

3:21:55 PM: info bootstrap finished - 5.447 s

3:21:55 PM: ⠀

3:21:55 PM: warning Browserslist: caniuse-lite is outdated. Please run:

3:21:55 PM: npx browserslist@latest --update-db

3:22:00 PM: warning Browserslist: caniuse-lite is outdated. Please run:

3:22:00 PM: npx browserslist@latest --update-db

3:22:30 PM: success Building production JavaScript and CSS bundles - 35.122s

3:22:30 PM: success Rewriting compilation hashes - 0.001s

3:22:31 PM: success run queries - 36.593s - 27/27 0.74/s

3:22:38 PM: success Building static HTML for pages - 7.246s - 24/24 3.31/s

3:22:38 PM: success Generating image thumbnails - 43.855s - 15/15 0.34/s

3:22:38 PM: info Generated public/sw.js, which will precache 8 files, totaling 427943 bytes.

3:22:38 PM: The following pages will be precached:

3:22:38 PM: /offline-plugin-app-shell-fallback/index.html

3:22:38 PM: success onPostBuild - 0.101s

3:22:38 PM: info Done building in 49.411443349 sec

3:22:39 PM: ​

3:22:39 PM: (build.command completed in 49.9s)

3:22:39 PM: ​

3:22:39 PM: ────────────────────────────────────────────────────────────────

3:22:39 PM: Netlify Build Complete

3:22:39 PM: ────────────────────────────────────────────────────────────────

3:22:39 PM: ​

3:22:39 PM: (Netlify Build completed in 50s)

3:22:39 PM: Caching artifacts

3:22:39 PM: Started saving node modules

3:22:39 PM: Finished saving node modules

3:22:39 PM: Started saving build plugins

3:22:39 PM: Finished saving build plugins

3:22:39 PM: Started saving pip cache

3:22:39 PM: Finished saving pip cache

3:22:39 PM: Started saving emacs cask dependencies

3:22:39 PM: Finished saving emacs cask dependencies

3:22:39 PM: Started saving maven dependencies

3:22:39 PM: Finished saving maven dependencies

3:22:39 PM: Started saving boot dependencies

3:22:39 PM: Finished saving boot dependencies

3:22:39 PM: Started saving rust rustup cache

3:22:39 PM: Finished saving rust rustup cache

3:22:39 PM: Started saving rust cargo bin cache

3:22:39 PM: Finished saving rust cargo bin cache

3:22:39 PM: Started saving go dependencies

3:22:39 PM: Finished saving go dependencies

3:22:41 PM: Build script success

3:22:41 PM: Starting to deploy site from ‘public’

3:22:41 PM: Creating deploy tree

3:22:41 PM: Creating deploy upload records

3:22:41 PM: 0 new files to upload

3:22:41 PM: 0 new functions to upload

3:22:42 PM: Starting post processing

3:22:42 PM: Post processing - HTML

3:22:42 PM: Post processing - header rules

3:22:42 PM: Post processing - redirect rules

3:22:42 PM: Post processing done

3:22:42 PM: Site is live :sparkles:

3:23:08 PM: Finished processing build request in 2m37.936047163s

The better the post - the faster the answer.

That generally doesn’t happen. Did you try to clear cache and deploy?

I’m using git for a PHP project, I think it’s really handy. There is one thing that would be great if I get it to work.

I have created a branch, meant for deployment. It has some differences, like different configuration files and documentation.

I can’t just ignore them, because then they will stay in both branches, while I would like to keep them different in both branches.

The problem is that when I merge the branches, those files that are meant to be different are merged too.

Is there any convenient way to accomplish such a thing? How is this normally done?

Walgreenslistens

That’s actually a Git related question I think. However that’s what merging a branch does. It syncs all differences. The only other way I know of might be to add those different files to .gitignore and keep all those files seperate.