Increase function timeouts

Hello,

I have a netlify app ( kaleidoscopic-moxie-0fbcb8.netlify.app) that is using gpt-3.5-turbo. It was working fine 4 months ago, but recently gpt response times have gotten slower and slower. It is now triggering the 10s timeout error. The gpt responses seem to be averaging about 15-20 seconds. (The functions aren’t doing anything other than awaiting a response). Is there any way you can raise that timeout limit?

Thanks

Solbein

Hi there! we can definitely bump you up to 26 seconds, but you’ll need to be on the Pro tier for us to make that change - that’s a requirement that applies to everyone who wants a bigger timeout. You can upgrade to Pro easily through the Netlify UI dashboard.

If you let us know when you have upgraded, we can change the settings for you!