Home
Support Forums

I'm getting deploment failed error

PLEASE help us help me out,
I’m using nextjs

2:04:44 PM: Build ready to start
2:04:46 PM: build-image version: fd3b56fcdbaad56e70919e8a4b2da9b411ec3532 (xenial)
2:04:46 PM: build-image tag: v3.10.1
2:04:46 PM: buildbot version: fa6cc7f6d011b8899be97010416c5b5974d37673
2:04:46 PM: Building without cache
2:04:46 PM: Starting to prepare the repo for build
2:04:46 PM: No cached dependencies found. Cloning fresh repo
2:04:46 PM: git clone GitHub - Netcom2017/web
2:04:48 PM: Preparing Git Reference refs/heads/master
2:04:49 PM: Parsing package.json dependencies
2:04:49 PM: Starting build script
2:04:49 PM: Installing dependencies
2:04:49 PM: Python version set to 2.7
2:04:51 PM: v12.18.0 is already installed.
2:04:52 PM: Now using node v12.18.0 (npm v6.14.4)
2:04:52 PM: Started restoring cached build plugins
2:04:52 PM: Finished restoring cached build plugins
2:04:52 PM: Attempting ruby version 2.7.1, read from environment
2:04:53 PM: Required ruby-2.7.1 is not installed - installing.
2:04:54 PM: Searching for binary rubies, this might take some time.
2:04:54 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2
2:04:54 PM: Checking requirements for ubuntu.
2:04:54 PM: Requirements installation successful.
2:04:55 PM: ruby-2.7.1 - #configure
2:04:55 PM: ruby-2.7.1 - #download
2:04:56 PM: ruby-2.7.1 - #validate archive
2:05:01 PM: ruby-2.7.1 - #extract
2:05:04 PM: ruby-2.7.1 - #validate binary
2:05:05 PM: ruby-2.7.1 - #setup
2:05:05 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global
2:05:06 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems…
2:05:06 PM: ruby-2.7.1 - #generating global wrappers…
2:05:06 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1
2:05:06 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
2:05:07 PM: ruby-2.7.1 - #generating default wrappers…
2:05:07 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1
2:05:08 PM: Using ruby version 2.7.1
2:05:08 PM: Using PHP version 5.6
2:05:08 PM: Started restoring cached yarn cache
2:05:08 PM: Finished restoring cached yarn cache
2:05:09 PM: Found yarn version (1.22.10) that doesn’t match expected (1.22.4)
up to date in 0.035s
2:05:10 PM: Installing yarn at version 1.22.4
2:05:10 PM: Installing Yarn!
2:05:10 PM: > Downloading tarball…
2:05:10 PM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz → /tmp/yarn.tar.gz.2unj2ldHVB
2:05:10 PM: % Total % Received % Xferd Average Speed Time Time Time Current
2:05:10 PM: Dload Upload Total Spent Left Speed
2:05:10 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
2:05:10 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
2:05:10 PM: 100 79 100 79 0 0 285 0 --:–:-- --:–:-- --:–:-- 285
2:05:10 PM: 100 93 100 93 0 0 135 0 --:–:-- --:–:-- --:–:-- 135
2:05:10 PM: 100 625 100 625 0 0 646 0 --:–:-- --:–:-- --:–:-- 646
2:05:11 PM: 82 1215k 82 998k 0 0 809k 0 0:00:01 0:00:01 --:–:-- 809k
2:05:11 PM: 100 1215k 100 1215k 0 0 970k 0 0:00:01 0:00:01 --:–:-- 11.1M
2:05:11 PM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc → /tmp/yarn.tar.gz.2unj2ldHVB.asc
2:05:11 PM: 100 83 100 83 0 0 1381 0 --:–:-- --:–:-- --:–:-- 1381
2:05:11 PM: 100 97 100 97 0 0 1098 0 --:–:-- --:–:-- --:–:-- 1098
2:05:11 PM: 100 629 100 629 0 0 3544 0 --:–:-- --:–:-- --:–:-- 3544
2:05:11 PM: 100 1028 100 1028 0 0 4388 0 --:–:-- --:–:-- --:–:-- 4388
2:05:11 PM: > Verifying integrity…
2:05:11 PM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
2:05:11 PM: gpg: Good signature from “Yarn Packaging yarn@dan.cx
2:05:11 PM: gpg: WARNING: This key is not certified with a trusted signature!
2:05:11 PM: gpg: There is no indication that the signature belongs to the owner.
2:05:11 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310
2:05:11 PM: Subkey fingerprint: 6D98 490C 6F1A CDDD 448E 4595 4F77 6793 6947 5BAA
2:05:11 PM: > GPG signature looks good
2:05:11 PM: > Extracting to ~/.yarn…
2:05:11 PM: > Adding to $PATH…
2:05:12 PM: > Successfully installed Yarn 1.22.4! Please open another terminal where the yarn command will now be available.
2:05:12 PM: No yarn workspaces detected
2:05:12 PM: Started restoring cached node modules
2:05:12 PM: Finished restoring cached node modules
2:05:12 PM: Installing NPM modules using Yarn version 1.22.4
2:05:13 PM: yarn install v1.22.4
2:05:13 PM: warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
2:05:13 PM: [1/4] Resolving packages…
2:05:13 PM: warning next > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
2:05:14 PM: [2/4] Fetching packages…
2:05:14 PM: error An unexpected error occurred: “https://npm.fontawesome.com/@fortawesome/fontawesome-svg-core/-/1.2.35/fontawesome-svg-core-1.2.35.tgz: Request failed “401 Unauthorized””.
2:05:14 PM: info If you think this is a bug, please open a bug report with the information provided in “/opt/build/repo/yarn-error.log”.
2:05:14 PM: info Visit yarn install | Yarn for documentation about this command.
2:05:14 PM: Error during Yarn install
2:05:14 PM: Build was terminated: Build script returned non-zero exit code: 1
2:05:14 PM: Creating deploy upload records
2:05:14 PM: Failing build: Failed to build site
2:05:14 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1
2:05:14 PM: Finished processing build request in 28.777919353s

Hi @netcomNet

This package requires authentication to download. You might find this following support guide useful