I still have no idea why the redirects aren't working

For some background, I’ve literally been reading support forums for the entire day…

So, my deployed site (via github).

There’s the main branch, which holds the _redirects file, the index.html file, the README, the license, and 3 folders:

  • site
  • css
  • media

There’s nothing in the Build Directories, as the site opens up the index, and then from there you explore the rest of the site (held in site folder).

I wrote the _redirects file as such:

/home /site/home 200
/site/* /site/404 404

I even tried:
/* /site/404 404

The purpose here:

if you type:
https://sitename.netlify.app/home - I need it to take you to the ‘home.html’ located in the ‘site’ folder.

I also want a custom 404 page (which I made as 404.html in ‘site’ folder).

No matter what configuration I try, or even tests, nothing works. All the build logs says is 'post processing redirects, followed by post-processing done.

Please help.

P.S I’ve tried it with and without pretty URL.
Note: I’m not super willing to share the directory (which is why I tried my best to explain the layout). Reasoning is that it’s a private ‘interactive letter’ I’m working on, if that makes sense?

Hey @GlyphicPyxel,

The redirects that you shared, should work, so if you say it doesn’t work, we would need some more info like:

  1. What happens when you say, “nothing works”? Do you get an error? It redirects to the wrong page? It doesn’t redirect at all? Something else?

  2. A site ID, account ID, test case, or something that we can try on our end would be useful too.

  1. The redirects don’t work. Since the site is WIP, for now, I want all sites and URLs to redirect to the WIP page. For instance, if you immediately jump to /site/home.html, it needs to take you to /util/wip.html instead.

  2. I also want the ‘test’ redirect to take me to home, so I myself can bypass the ‘wip’ rule.

  3. Speaking of which, I’ve noticed some sites all operate under 1 ‘URL’ as in example.com, where no matter where you go on the site, the url doesn’t change. Whereas my url updates according to directory. Is there a way to stop that? The eventual aim of the site is to be a web app project only used by 1 person.

Like we said, we need:

It’s hard to debug a case by reading words without seeing the problem happen.