I get a success message by default in the Contact Us function. Is there any way to prevent this from happening?

When I click the link to go back to the original page, a blank page appears and the site stops working.

The following message will be displayed.

Thank you!

Your form submission has been received.
← Back to our site

Then it goes back to the Contact Us page, but it’s a blank page.




{{ errors[0] }}


{{ errors[0] }}

        v-slot="{ errors }"
        <p v-show="errors.length" class="contact_error">{{ errors[0] }}</p>
    <div class="" v-show="false">
    <div class="flex justify-center">
      <button class="btn rounded-md" type="submit" :disabled="invalid || !validated">


Hi, @genki.

This Support Guide covers debugging forms issues. There are also many other Support Guides for forms - you can find them here: #Netlify-support:support-guides

We also recommend trying to search the forums or look at topics tagged Netlify forms if you haven’t already - it’s likely your question was already asked by someone else!

If you are still having problems, please provide more information such as what you have already tried, and a link to your live form. Our support team cannot troubleshoot custom code but we are happy to examine the live form if you send us a link to it.

You can post that information publicly or you can private message (PM) that to one of our support staff. I’ve confirmed that PMs are enabled for your community login. Please keep in mind that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

#Success messages

By default, when visitors complete a form, they will see a generically styled success message with a link back to the form page. You can replace the default success message with a custom page you create by adding an action attribute to the <form> tag, entering the path of your custom page (like "/pages/success" ) as the value. The path must be relative to the site root, starting with a / .


I worked with the above document, but I get the default message.

The URL is transitioned, but the default message appears on that page and the same thing happens.

Hi, @genki. We still need a link to your deployed form to troubleshoot further.


This is the above site.

Please check it out.

Hey there,
It seems like you’ve removed the form from your site since writing in. Please let us know if you put it back and would like for us to take a look.