Home
Support Forums

I Can't submit sitemap.xml file in Google Search console

I Can’t submit sitemap.xml file in Google Search console.
(“mini-militia.netlify.app/sitemap.xml”)

When i submit my sitemap in Google Search console it’s show me (“Couldn’t fetch”)
My sitemap is a clean and pure.

I can submit my sitemap of (“myname.github.io/sitemap.xml”) in search console.

But netlify website show me this error message (“Couldn’t fetch”) .
From 2 day it’s show me problem.
What i do now?

For the past 2-3 days I have difficulty submitting a sitemap on the Google search engine using the NetLify platform. A sitemap always can’t be fetched but a sitemap can be opened.

hi there, I have merged these two posts together because they seem to be the same issue.

Have either of you previously successfully submitted a sitemap?

Are either of you using the sitemap build plugin?

I have previously successfully submitted a sitemap.

I have solved my problem today.
This is because my website page is not mobile friendly.
But i have solved it.

Next time if i see any problems then i will ask you.
Thanks for reply.

Hi, @MunnyReol, thanks for letting us know you got it working. @adsbhd, would you please send us a link to the sitemap.xml which isn’t working at Google search engine?

My Problem Was Solved

how did you solved i am currently facing this error about 15 days Couldn’t fetch . my website is mobile friendly . i tested with github sitemap got success but with netlify i am getting error

Hi there, glad you found us :wave: before we can help you, we need a little more information on the issues you are facing.

Please tell us:

  • the name of your build instance: “example-jones.netlify.com
  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console