Home
Support Forums

I can't find my sitemap.xml

I can’t find my sitemap.xml.
My domain is; simpleinternettools.netlify.app

my netlify.toml has this;

[[plugins]]
package = "@netlify/plugin-sitemap"

  [plugins.inputs]
  buildDir = "public"
  prettyURLs = true
  # Append missing trailing slash to pretty URL
  trailingSlash = true

Hi @Steven_O,

You’re using manual deploys. Such deploys cannot (fully) use build-plugins. So, if you could switch to a Git-based deploy system and let us know how it goes, that’d be great.

1 Like

Switched to a git-based deploy. I still can’t find /sitemap.xml

That’s because the plugin is still not installed from the UI: https://app.netlify.com/sites/simpleinternettools/plugins. Go there and add the sitemap plugin. If you wish to add the plugin only through netlify.toml, you need to add it in your package.json too: Build Plugins | Netlify Docs.

I have installed the plugin from the UI. However, the /sitemap.xml is still not showing.

Your latest deploy seems to be the one before adding the plugin. Did you re-deploy after adding it?

No, I did not redeploy. It is the exact website copy I had on my local drive (which was also my last manual deploy) that I pushed to github.

Now that you’ve configured your website to deploy from Git and added the plugin, you need to push to your repo again. Then you could see the changes.

Just redeployed. The /sitemap.xml is still not showing.

I believe it’s because your publish directory is empty:

Would you try setting / there? And yes, once you do that, you’d have to re-deploy.

I have added the / and redeployed. Still, the /sitemap.xml is not showing.

That is a strange one. I just uploaded a test website and it worked. What’s surprising to me is that, it’s not showing ‘plugin ran successfully’ in the UI for you.

This is how it showing for my test website:

This is how it’s showing for your website:

I don’t really have an explanation for this at the moment. Would it be possible for you to take your repo public so we could test what’s happening and narrow down the problem? It appears that all other settings are correct now. So, it should work, yet it won’t.

I have made the repo public. Deployment summary shows that 1 plugin ran successfully. However /sitemap.xml is not still showing

Oh, it’s probably because you still have your netlify.toml file with the following contents:

  [plugins.inputs]
  buildDir = "public"
  prettyURLs = true
  # Append missing trailing slash to pretty URL
  trailingSlash = true

Here your directory is configured as public. You don’t need the file anymore. It’s better to delete it since you’ve added the plugin via UI.

I can see that a sitemap is now up and running for you. If you’ve any more questions, let us know.

Yes it is. Thanks a billion!!!