Support Forums

How to remove dangling DNS entries

I have setup some toy projects, all using the netlify DNS with an externally bought domain.
Everything was working as expected: I created a new site, set the custom sub-domain (like slides.mene.dev) and the expected entries appeared in the DNS. However I then deleted the Project and the DNS is still setup.
In the place of the old entry I’d like to set a custom one (CNAME), but I can’t because it still says “This is a system record that cannot be managed directly.”

How to remove those entries?


Hi @Mene,

When you delete a site that has a domain on it and you are using Netlify managed DNS, it doesn’t remove the DNS zone or the DNS records on it. If you want to remove any existing records then you can modify your DNS zone from this page.

Thanks for your answer. I am on this page where it says “This is a system record that cannot be managed directly” even after I deleted the site. I don’t see how to delete any of those entries.

1 Like

Same issue here. Plus, the domain I want to delete/manage points to an IP which is shown to be of DigitalOcean (?).

How do I modify my subdomain DNS pointer?

My solution for now was to delete the complete DNS zone. When you recreate it all the Subdomains are added automatically.

1 Like

@cub33 - did you try what @Mene suggested?

@perry no, I solved by switching the nameservers back to the main DNS register

I keep having this happen and each time I just contact Netlify support asking them to remove the record and they are able to. Its annoying and Netlify needs to look into a solution.

1 Like

At this time, there is an open feature request to be able to delete the NETLIFY/NETLIFYv6 type DNS records in Managed DNS.

We’ll update this topic if/when the ability to delete these records in the UI becomes available.

In the meantime, @oscartbeaumont’s comment is correct. Please let our support team know which records to delete. We are happy to do so if you are the/an owner of the team that owns the Managed DNS zone configuration in question.

Being able to delete them is cool and would fix the problem but shouldn’t you investigate why they are not being deleted as it only happens sometimes?

hey @oscartbeaumont - investigating is definitely part of the process! We’ll update this thread as soon as more information becomes available - at the mean time, let us know if you have records that need to be deleted :muscle:

The support doesn’t do anything if you’re on the free plan:
" Users on our free plan receive support in the Netlify Community where you’ll find answers from our Netlify Support engineers and the wider community."

And Netflix Community can’t delete the leaked DNS records. I guess I’ll just switch back to the old DNS.

in select cases (for example things like this) we can definitely step in and help. I recommend you add a post in the #admin section of this forum with some account details, and we’ll assist you!

Hi guys, I’m also unable to delete a DNS record associated with my account. If someone from Netlify support could help out, that would be great!

hi bo-dun, we responded on your other thread.

I tried deleting my DNS zone etc but I too seem to still have a problem where the DNS is still pointing to netlify.

hi @dtime35, we can’t really help much without some more specifics :slight_smile: which site is this regarding?

Hello I’m having issues removing genesisabelab.com. please assist

hi there neydoo,

this is actually something you can do yourself, now!

in case you want to remove the name from the site, it can be done here: Netlify App . You’ll need to be logged in for that link to work.

If you want to remove our DNS hosting of the domain, they can do that here: Netlify App

let us know if that helps!

It still doesn’t work. it returns this message when I delete the custom domain
Not Found - Request ID: 01F…
on re-adding the custom domain, the site loads up