How to disable mixed content detection/notifications?

Netlify is flagging a namespace URI, in this case http://purl.org/dc/elements/1.1/, as “mixed content”. I don’t actually have mixed content It’s kinda annoying to get an email notification when I deploy my site.

Here’s the log (although I don’t think you need it):

3:37:14 PM: Post processing - HTML
3:37:14 PM: Mixed content detected in: /404.html
3:37:14 PM: --> insecure link urls:
3:37:14 PM:   - http://purl.org/dc/elements/1.1/
3:37:14 PM: Mixed content detected in: /projetos/math-express/index.html
3:37:14 PM: --> insecure link urls:
3:37:14 PM:   - http://purl.org/dc/elements/1.1/
3:37:14 PM: Mixed content detected in: /index.html
3:37:14 PM: --> insecure link urls:
3:37:14 PM:   - http://purl.org/dc/elements/1.1/
3:37:14 PM: Mixed content detected in: /e-mail.html
3:37:14 PM: --> insecure link urls:
3:37:14 PM:   - http://purl.org/dc/elements/1.1/
3:37:14 PM: Mixed content detected in: /projetos/cábulas-calc/instruções-transf-windows.html
3:37:14 PM: --> insecure link urls:
3:37:15 PM:   - http://purl.org/dc/elements/1.1/
3:37:15 PM: Mixed content detected in: /projetos/cábulas-calc/instruções-de-visualização.html
3:37:15 PM: --> insecure link urls:
3:37:15 PM:   - http://purl.org/dc/elements/1.1/
3:37:15 PM: Mixed content detected in: /sobre/info-legal.html
3:37:15 PM: --> insecure link urls:
3:37:15 PM:   - http://purl.org/dc/elements/1.1/
3:37:15 PM: Mixed content detected in: /projetos/cábulas-calc/como-fazer-cábulas.html
3:37:15 PM: --> insecure link urls:
3:37:15 PM:   - http://purl.org/dc/elements/1.1/
3:37:15 PM: Mixed content detected in: /projetos/cábulas-calc/index.html
3:37:15 PM: --> insecure link urls:
3:37:15 PM:   - http://purl.org/dc/elements/1.1/

Could you not update the references to point to https://purl.org/dc/elements/1.1/? Then, you’re quashing the error itself and not suppressing the warning :smiley:!

Thanks for your reply. Unfortunately, https://purl.org/dc/elements/1.1/ is actually a completely different namespace from http://purl.org/dc/elements/1.1/. From WHATWG:

Humans make a number of assumptions about how URLs can be changed (capitalization, trailing /, http vs https, www or not, etc) which are often true for real URLs due to nice server software, but are not true for namespaces, which are opaque strings.

You could perhaps proxy to the content:

/purl-elements http://purl.org/dc/elements/1.1/ 200

This is a namespace. Namespaces are not links; they’re just strings that often have the structure of an URL, but are not interpreted as URLs. Changing the namespace, even slightly, is not an option, as it would completely change its meaning.

The namespace string is getting incorrectly flagged as “mixed content”, so I would like to disable mixed content alerts.

Edit: This isn’t a big deal for me, as I might remove that namespace in the future.

D’oh. Sorry about that, it’s finally clicked. That’ll teach me for rushing.

I’ve taken a look at DCMI: Expressing Dublin Core™ metadata using HTML/XHTML meta and link elements which states:

For all DCMI terms, the convention used by the DCMI community is to split the term URI into an expanded name at the right-most ‘/’ (forward slash) character (as in the first example above). Also, the characters used for the prefix in a DC-HTML Prefixed Name are not significant, but communities often adopt a convention on the common use of a prefix to facilitate human readability.

From this, perhaps I’m wrong in assuming: anything before (and including) the // for the protocol is added for mere readability and can be altered?

I believe the “DC-HTML Prefixed Name” refers to the name attribute in the meta element, not to the namespace URL.

From the webpage you linked to:

The following examples shows a namespace declaration and the use of a DC-HTML Prefixed Name for the value of the name attribute of the meta element:

Example 5: DC-HTML Prefixed Name as attribute value (HTML)

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"
   "http://www.w3.org/TR/html4/strict.dtd">
<html>
  <head profile="http://dublincore.org/specifications/dublin-core/dc-html/2008-08-04/">
    <title>Services to Government</title>
    <link rel="schema.DC" href="http://purl.org/dc/elements/1.1/" >
    <meta name="DC.title" content="Services to Government" >
  </head>
  <body>
  </body>
</html>

In that case, the “DC-HTML Prefixed Name” is DC.title, and its prefix is DC. “The characters used for the prefix in a DC-HTML Prefixed Name are not significant” means that DC could be replaced by any other prefix.


In the absence of a better solution, I created a filter in my email account that automatically deletes messages from Netlify about mixed content. It’s a bit hacky, but it should work for me.

I’d just like to +1 the ability to disable this. My content site has 6k+ blog posts, many of them written before https was widely and easily available. I could go back and fix them all, but that’s going to take a long time. Would much rather just have the ability to turn this off.

Thanks for chiming in here, @cfjedimaster :slight_smile:

Would you like us to open a feature request for this? Additionally, have you tried the above step that @rodri60 shared of creating a filter in your email?

Yes please. It’s not a huge bother at all, but I’d like to “officially” request it. :slight_smile:

1 Like

no problem, we added your voice to the already open feature request! Thanks for being so engaged, Raymond :slight_smile:

Any update on this?
Is the feature request public?
Thanks.

I ask because we see this as a recurring problem too.
It’s also with PURLs which are specifically HTTP.
This is generated by other tooling which we cannot modify.

hi @relequestual and thanks for asking!

The feature request is tracked in internal systems, but this thread is a great place to upvote.

This is not something we’ve implemented yet nor have any immediate plans to, so hopefully you can work around it with filters in your mail client, or by instead sending your notifications through a system like zapier that can examine the contents and choose not to forward them to you if you’ve deemed them non-actionable.

I’d also really like to be able to turn these notifications off. I’m getting it for decade-old posts that haven’t been touched in a long time. This is just one more thing Netlify could do to be helpful, and I’d love to just turn it off in the Netlify GUI.

I’m aware that I can use mail filters or use a whole Zapier set up, but another way to look at this is that I never opted in to these warnings, and Netlify goes ahead and emails me on every build. Shouldn’t we be able to opt out?

Hey @sahandnayebaziz

While I don’t (at least in part) disagree with your sentiment that users could/should have the ability to opt-out of these warning, in an environment where HTTPS is generally now the norm rather than the exception (especially on Netlify where it is the norm), having mixed-media can (and will) often stop websites from loading correctly in modern browsers.

So these notifications serve as a reminder that there is content that could/should get updated to use HTTPS, not HTTP, in order to ensure continued functionality of the site(s).

1 Like

+1 on letting us disable the warning. I have mixed protocol because I’m syndicating other people’s blog articles for which I have no control over what URLs they use.

Also, https does not necessarily mean it’s better than http. From the creator of the web: TLS Everywhere, not https: URIs - Design Issues (w3.org)

Hey there, @chuanqisun :wave:

Thanks so much for reaching out! I have shared your feedback with the appropriate team.