Home
Support Forums

How change npm install default netlify to npm install --force

2:44:34 PM: npm ERR! Fix the upstream dependency conflict, or retry

2:44:34 PM: npm ERR! this command with --force, or --legacy-peer-deps

2:44:34 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1

2:44:34 PM: npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

i get this error halp me

Hi @crmlife

If you want to use --force or --legacy-peer-deps set the NPM_FLAGS environment variable either in the Netlify UI (see below) of in a netlify.toml.

ok solved thanks for your help