Home
Support Forums

Help! Problem with deploying my site

I get this:

9:34:22 PM: Build ready to start

9:34:24 PM: build-image version: 2cee85eb7f808bf3b6e87378c5307f9411f0a332

9:34:24 PM: build-image tag: v3.8.0

9:34:24 PM: buildbot version: fb1691e123b163167156a643d7042e525001587f

9:34:24 PM: Building without cache

9:34:24 PM: Starting to prepare the repo for build

9:34:25 PM: No cached dependencies found. Cloning fresh repo

9:34:25 PM: git clone https://github.com/LETS-Zottegem/site

9:34:26 PM: Preparing Git Reference refs/heads/master

9:34:27 PM: Parsing package.json dependencies

9:34:27 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: โ€˜buildโ€™ versus โ€˜build/โ€™ in the Netlify UI

9:34:27 PM: Starting build script

9:34:27 PM: Installing dependencies

9:34:27 PM: Python version set to 2.7

9:34:28 PM: v12.18.0 is already installed.

9:34:29 PM: Now using node v12.18.0 (npm v6.14.4)

9:34:29 PM: Started restoring cached build plugins

9:34:29 PM: Finished restoring cached build plugins

9:34:29 PM: Attempting ruby version 2.7.1, read from environment

9:34:30 PM: Required ruby-2.7.1 is not installed - installing.

9:34:30 PM: Searching for binary rubies, this might take some time.

9:34:30 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2

9:34:30 PM: Checking requirements for ubuntu.

9:34:31 PM: Requirements installation successful.

9:34:31 PM: ruby-2.7.1 - #configure

9:34:31 PM: ruby-2.7.1 - #download

9:34:32 PM: ruby-2.7.1 - #validate archive

9:34:36 PM: ruby-2.7.1 - #extract

9:34:39 PM: ruby-2.7.1 - #validate binary

9:34:39 PM: ruby-2.7.1 - #setup

9:34:40 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global

9:34:40 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gemsโ€ฆ

9:34:40 PM: ruby-2.7.1 - #generating global wrappersโ€ฆ

9:34:40 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1

9:34:41 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list

9:34:41 PM: ruby-2.7.1 - #generating default wrappersโ€ฆ

9:34:41 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1

9:34:42 PM: Using ruby version 2.7.1

9:34:42 PM: Using PHP version 5.6

9:34:42 PM: Started restoring cached node modules

9:34:42 PM: Finished restoring cached node modules

9:34:42 PM: Installing NPM modules using NPM version 6.14.4

9:34:44 PM: npm ERR! code ENOTSUP

9:34:44 PM: npm ERR! notsup Unsupported engine for @sveltejs/kit@1.0.0-next.121: wanted: {โ€œnodeโ€:"^12.20 || >=14.13"} (current: {โ€œnodeโ€:โ€œ12.18.0โ€,โ€œnpmโ€:โ€œ6.14.4โ€})

9:34:44 PM: npm ERR! notsup Not compatible with your version of node/npm: @sveltejs/kit@1.0.0-next.121

9:34:44 PM: npm ERR! notsup Not compatible with your version of node/npm: @sveltejs/kit@1.0.0-next.121

9:34:44 PM: npm ERR! notsup Required: {โ€œnodeโ€:"^12.20 || >=14.13"}

9:34:44 PM: npm ERR! notsup Actual: {โ€œnpmโ€:โ€œ6.14.4โ€,โ€œnodeโ€:โ€œ12.18.0โ€}

9:34:44 PM: Creating deploy upload records

9:34:44 PM: npm ERR! A complete log of this run can be found in:

9:34:44 PM: npm ERR! /opt/buildhome/.npm/_logs/2021-07-06T19_34_44_660Z-debug.log

9:34:44 PM: Error during NPM install

9:34:44 PM: Build was terminated: Build script returned non-zero exit code: 1

9:34:45 PM: Failing build: Failed to build site

9:34:45 PM: Failed during stage โ€˜building siteโ€™: Build script returned non-zero exit code: 1

9:34:45 PM: Finished processing build request in 20.697105784s

What can I do? Iโ€™m a new user for this.

This is my site: https://lets-zottegem.netlify.app/

I work with:
Visual studio code
Version: 1.57.1
Commit: 507ce72a4466fbb27b715c3722558bb15afa9f48
Date: 2021-06-17T13:26:56.255Z
Electron: 12.0.7
Chrome: 89.0.4389.128
Node.js: 14.16.0
V8: 8.9.255.25-electron.0
OS: Linux x64 5.4.0-77-generic snap

Iโ€™ve seen that my changes are updated to githup.

Hi @Jorisvh

It appears the node version used is incorrect

You can specify which node version to use as outlined in Manage build dependencies | Netlify Docs

I want to update my node version, but I donโ€™t know how to do this. Iโ€™m new here.

Have a look at Netlifyโ€™s docs, specifically Node.js and JavaScript which outlines the two ways you can do this.

Spoiler

You can choose the Node.js version we use to build your site in two different ways:

  • Set a NODE_VERSION environment variable.
  • Add a .node-version or .nvmrc file to the siteโ€™s base directory in your repository. This will also tell any other developer using the repository which version of Node.js it depends on.

We all were once. Stick around, itโ€™s a great place :smiley:

1 Like

I did this in netlify.


I still get the same errors in deployment.

This is not what i want. I want to update node version on my computer. How can I do this?

What will depend on the method used to install node in the first place and what operating system you are using. I used Homebrew so I use commands specific to them. You can download binaries directly from Node.js website.

My OS is Ubuntu 20.04.2 LTS. I prefere to use commands.

https://help.ubuntu.com/community/AptGet/Howto

I did this:

curl -fsSL https://deb.nodesource.com/setup_16.x | sudo -E bash -
sudo apt-get install -y nodejs

This is still my Deploy log

7:20:09 PM: Build ready to start
7:20:11 PM: build-image version: 2cee85eb7f808bf3b6e87378c5307f9411f0a332
7:20:11 PM: build-image tag: v3.8.0
7:20:11 PM: buildbot version: d9a660540b05c414edfc0246347871ef0e3afee9
7:20:11 PM: Fetching cached dependencies
7:20:11 PM: Failed to fetch cache, continuing with build
7:20:11 PM: Starting to prepare the repo for build
7:20:11 PM: No cached dependencies found. Cloning fresh repo
7:20:11 PM: git clone https://github.com/LETS-Zottegem/site
7:20:13 PM: Preparing Git Reference refs/heads/master
7:20:14 PM: Parsing package.json dependencies
7:20:14 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'build' versus 'build/' in the Netlify UI
7:20:14 PM: Starting build script
7:20:14 PM: Installing dependencies
7:20:14 PM: Python version set to 2.7
7:20:16 PM: Downloading and installing node v12.18.4...
7:20:16 PM: Downloading https://nodejs.org/dist/v12.18.4/node-v12.18.4-linux-x64.tar.xz...
7:20:16 PM: Computing checksum with sha256sum
7:20:16 PM: Checksums matched!
7:20:19 PM: Now using node v12.18.4 (npm v6.14.6)
7:20:19 PM: Started restoring cached build plugins
7:20:19 PM: Finished restoring cached build plugins
7:20:19 PM: Attempting ruby version 2.7.1, read from environment
7:20:20 PM: Required ruby-2.7.1 is not installed - installing.
7:20:21 PM: Searching for binary rubies, this might take some time.
7:20:21 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2
7:20:21 PM: Checking requirements for ubuntu.
7:20:22 PM: Requirements installation successful.
7:20:22 PM: ruby-2.7.1 - #configure
7:20:22 PM: ruby-2.7.1 - #download
7:20:22 PM: ruby-2.7.1 - #validate archive
7:20:28 PM: ruby-2.7.1 - #extract
7:20:31 PM: ruby-2.7.1 - #validate binary
7:20:31 PM: ruby-2.7.1 - #setup
7:20:32 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global
7:20:32 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems........................................
7:20:33 PM: ruby-2.7.1 - #generating global wrappers........
7:20:33 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1
7:20:33 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
7:20:34 PM: ruby-2.7.1 - #generating default wrappers........
7:20:34 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1
7:20:35 PM: Using ruby version 2.7.1
7:20:35 PM: Using PHP version 5.6
7:20:35 PM: Started restoring cached node modules
7:20:35 PM: Finished restoring cached node modules
7:20:35 PM: Installing NPM modules using NPM version 6.14.6
7:20:36 PM: npm ERR! code ENOTSUP
7:20:36 PM: npm ERR! notsup Unsupported engine for sveltekit-test@0.0.1: wanted: {"node":">=12.20"} (current: {"node":"12.18.4","npm":"6.14.6"})
7:20:36 PM: npm ERR! notsup Not compatible with your version of node/npm: sveltekit-test@0.0.1
7:20:36 PM: npm ERR! notsup Not compatible with your version of node/npm: sveltekit-test@0.0.1
7:20:36 PM: npm ERR! notsup Required: {"node":">=12.20"}
7:20:36 PM: npm ERR! notsup Actual:   {"npm":"6.14.6","node":"12.18.4"}
7:20:36 PM: npm ERR! A complete log of this run can be found in:
7:20:36 PM: npm ERR!     /opt/buildhome/.npm/_logs/2021-07-14T17_20_36_641Z-debug.log
7:20:36 PM: Error during NPM install
7:20:36 PM: Build was terminated: Build script returned non-zero exit code: 1
7:20:36 PM: Creating deploy upload records
7:20:36 PM: Failing build: Failed to build site
7:20:36 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1
7:20:36 PM: Finished processing build request in 25.711813193s

Hey @Jorisvh have you tried adding a .nvmrc file in your projects root with the value of v14?

This should tell Netlify to use NodeV14 to build your site since it looks like Svelte requires a version higher than 12.20.

I did this.

But the problem isnโ€™t solved.
See

8:19:34 PM: Build ready to start
8:19:36 PM: build-image version: 2cee85eb7f808bf3b6e87378c5307f9411f0a332
8:19:36 PM: build-image tag: v3.8.0
8:19:36 PM: buildbot version: d9a660540b05c414edfc0246347871ef0e3afee9
8:19:36 PM: Fetching cached dependencies
8:19:36 PM: Failed to fetch cache, continuing with build
8:19:36 PM: Starting to prepare the repo for build
8:19:37 PM: No cached dependencies found. Cloning fresh repo
8:19:37 PM: git clone https://github.com/LETS-Zottegem/site
8:19:38 PM: Preparing Git Reference refs/heads/master
8:19:39 PM: Parsing package.json dependencies
8:19:39 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'build' versus 'build/' in the Netlify UI
8:19:39 PM: Starting build script
8:19:39 PM: Installing dependencies
8:19:39 PM: Python version set to 2.7
8:19:40 PM: Attempting node version 'v14' from .nvmrc
8:19:41 PM: Downloading and installing node v14.17.3...
8:19:41 PM: Downloading https://nodejs.org/dist/v14.17.3/node-v14.17.3-linux-x64.tar.xz...
8:19:41 PM: Computing checksum with sha256sum
8:19:41 PM: Checksums matched!
8:19:45 PM: Now using node v14.17.3 (npm v6.14.13)
8:19:45 PM: Started restoring cached build plugins
8:19:45 PM: Finished restoring cached build plugins
8:19:45 PM: Attempting ruby version 2.7.1, read from environment
8:19:46 PM: Required ruby-2.7.1 is not installed - installing.
8:19:47 PM: Searching for binary rubies, this might take some time.
8:19:47 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2
8:19:47 PM: Checking requirements for ubuntu.
8:19:48 PM: Requirements installation successful.
8:19:48 PM: ruby-2.7.1 - #configure
8:19:48 PM: ruby-2.7.1 - #download
8:19:49 PM: ruby-2.7.1 - #validate archive
8:19:54 PM: ruby-2.7.1 - #extract
8:19:57 PM: ruby-2.7.1 - #validate binary
8:19:58 PM: ruby-2.7.1 - #setup
8:19:58 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global
8:19:59 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems........................................
8:19:59 PM: ruby-2.7.1 - #generating global wrappers........
8:19:59 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1
8:19:59 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
8:20:00 PM: ruby-2.7.1 - #generating default wrappers........
8:20:01 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1
8:20:01 PM: Using ruby version 2.7.1
8:20:01 PM: Using PHP version 5.6
8:20:01 PM: Started restoring cached node modules
8:20:01 PM: Finished restoring cached node modules
8:20:02 PM: Installing NPM modules using NPM version 6.14.13
8:20:06 PM: > esbuild@0.12.15 postinstall /opt/build/repo/node_modules/@sveltejs/adapter-node/node_modules/esbuild
8:20:06 PM: > node install.js
8:20:08 PM: > esbuild@0.12.15 postinstall /opt/build/repo/node_modules/@sveltejs/kit/node_modules/esbuild
8:20:08 PM: > node install.js
8:20:08 PM: > esbuild@0.9.7 postinstall /opt/build/repo/node_modules/esbuild
8:20:08 PM: > node install.js
8:20:09 PM: > svelte-preprocess@4.7.0 postinstall /opt/build/repo/node_modules/svelte-preprocess
8:20:09 PM: > echo "[svelte-preprocess] Don't forget to install the preprocessors packages that will be used: node-sass/sass, stylus, less, postcss & postcss-load-config, coffeescript, pug, etc..."
8:20:09 PM: [svelte-preprocess] Don't forget to install the preprocessors packages that will be used: node-sass/sass, stylus, less, postcss & postcss-load-config, coffeescript, pug, etc...
npm WARN @sveltejs/vite-plugin-svelte@1.0.0-next.12 requires a peer of vite@^2.3.7 but none is installed. You must install peer dependencies yourself.
8:20:09 PM: npm WARN sveltekit-test@0.0.1 No repository field.
8:20:09 PM: npm WARN sveltekit-test@0.0.1 No license field.
8:20:09 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
8:20:09 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
8:20:09 PM: added 62 packages from 128 contributors and audited 63 packages in 6.868s
8:20:09 PM: 5 packages are looking for funding
8:20:09 PM:   run `npm fund` for details
8:20:09 PM: found 1 moderate severity vulnerability
8:20:09 PM:   run `npm audit fix` to fix them, or `npm audit` for details
8:20:09 PM: NPM modules installed
8:20:10 PM: Started restoring cached go cache
8:20:10 PM: Finished restoring cached go cache
8:20:10 PM: go version go1.14.4 linux/amd64
8:20:10 PM: go version go1.14.4 linux/amd64
8:20:10 PM: Installing missing commands
8:20:10 PM: Verify run directory
8:20:10 PM: โ€‹
8:20:10 PM: โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€
8:20:10 PM:   Netlify Build                                                 
8:20:10 PM: โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€
8:20:10 PM: โ€‹
8:20:10 PM: โฏ Version
8:20:10 PM:   @netlify/build 15.11.2
8:20:10 PM: โ€‹
8:20:10 PM: โฏ Flags
8:20:10 PM:   deployId: 60ef2ab699b87d0008370b10
8:20:10 PM: โ€‹
8:20:10 PM: โฏ Current directory
8:20:10 PM:   /opt/build/repo
8:20:10 PM: โ€‹
8:20:10 PM: โฏ Config file
8:20:10 PM:   No config file was defined: using default values.
8:20:10 PM: โ€‹
8:20:10 PM: โฏ Context
8:20:10 PM:   production
8:20:10 PM: โ€‹
8:20:10 PM: โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€
8:20:10 PM:   1. Build command from Netlify app                             
8:20:10 PM: โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€
8:20:10 PM: โ€‹
8:20:10 PM: $ npm run build
8:20:11 PM: > sveltekit-test@0.0.1 build /opt/build/repo
8:20:11 PM: > svelte-kit build
8:20:11 PM: svelte.config.cjs should be renamed to svelte.config.js and converted to an ES module. See https://kit.svelte.dev/docs#configuration for an example
8:20:11 PM: No "exports" main defined in /opt/build/repo/node_modules/@sveltejs/adapter-node/package.json
8:20:11 PM: Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: No "exports" main defined in /opt/build/repo/node_modules/@sveltejs/adapter-node/package.json
8:20:11 PM:     at throwExportsNotFound (internal/modules/esm/resolve.js:285:9)
8:20:11 PM:     at packageExportsResolve (internal/modules/esm/resolve.js:474:7)
8:20:11 PM:     at resolveExports (internal/modules/cjs/loader.js:450:36)
8:20:11 PM:     at Function.Module._findPath (internal/modules/cjs/loader.js:490:31)
8:20:11 PM:     at Function.Module._resolveFilename (internal/modules/cjs/loader.js:888:27)
8:20:11 PM:     at Function.Module._load (internal/modules/cjs/loader.js:746:27)
8:20:11 PM:     at Module.require (internal/modules/cjs/loader.js:974:19)
8:20:11 PM:     at require (internal/modules/cjs/helpers.js:92:18)
8:20:11 PM:     at Object.<anonymous> (/opt/build/repo/svelte.config.cjs:2:14)
8:20:11 PM:     at Module._compile (internal/modules/cjs/loader.js:1085:14)
8:20:11 PM: npm ERR! code ELIFECYCLE
8:20:11 PM: npm ERR! errno 1
8:20:11 PM: npm ERR! sveltekit-test@0.0.1 build: `svelte-kit build`
8:20:11 PM: npm ERR! Exit status 1
8:20:11 PM: npm ERR!
8:20:11 PM: npm ERR! Failed at the sveltekit-test@0.0.1 build script.
8:20:11 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
8:20:11 PM: npm ERR! A complete log of this run can be found in:
8:20:11 PM: npm ERR!     /opt/buildhome/.npm/_logs/2021-07-14T18_20_11_428Z-debug.log
8:20:11 PM: โ€‹
8:20:11 PM: โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€
8:20:11 PM:   "build.command" failed                                        
8:20:11 PM: โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€โ”€
8:20:11 PM: โ€‹
8:20:11 PM:   Error message
8:20:11 PM:   Command failed with exit code 1: npm run build
8:20:11 PM: โ€‹
8:20:11 PM:   Error location
8:20:11 PM:   In Build command from Netlify app:
8:20:11 PM:   npm run build
8:20:11 PM: โ€‹
8:20:11 PM:   Resolved config
8:20:11 PM:   build:
8:20:11 PM:     command: npm run build
8:20:11 PM:     commandOrigin: ui
8:20:11 PM:     environment:
8:20:11 PM:       - NODE_VERSION
8:20:11 PM:     publish: /opt/build/repo/build
8:20:11 PM:     publishOrigin: ui
8:20:11 PM: Caching artifacts
8:20:11 PM: Started saving node modules
8:20:11 PM: Finished saving node modules
8:20:11 PM: Started saving build plugins
8:20:11 PM: Finished saving build plugins
8:20:11 PM: Started saving pip cache
8:20:11 PM: Finished saving pip cache
8:20:11 PM: Started saving emacs cask dependencies
8:20:11 PM: Finished saving emacs cask dependencies
8:20:11 PM: Started saving maven dependencies
8:20:11 PM: Finished saving maven dependencies
8:20:11 PM: Started saving boot dependencies
8:20:12 PM: Finished saving boot dependencies
8:20:12 PM: Started saving rust rustup cache
8:20:12 PM: Finished saving rust rustup cache
8:20:12 PM: Started saving go dependencies
8:20:12 PM: Finished saving go dependencies
8:20:15 PM: Cached ruby version 2.7.1
8:20:15 PM: Build failed due to a user error: Build script returned non-zero exit code: 2
8:20:15 PM: Creating deploy upload records
8:20:15 PM: Failing build: Failed to build site
8:20:15 PM: Failed during stage 'building site': Build script returned non-zero exit code: 2
8:20:15 PM: Finished processing build request in 39.613635684s

This looks like a dependency issue.

After I quick search I found these resources give them a read, you may find a solution.