Having trouble deploying 11ty site

I need help debugging a deploy for an 11ty starter template: https://app.netlify.com/sites/kind-cray-32943c/deploys/5f8b20421f46f000072d161a

I’ve tried different build commands, looked at other 11ty sites, and deployed a different 11ty starter listed in Netlify’s templates to compare settings. I just can’t figure out what I’m doing wrong. My coding and debugging skills are really on the light side, though.

Here are my Build Settings:

  • Build command: DEBUG=* eleventy
  • Publish directory: _site

Here’s a public gist for the Deploy Log: https://gist.github.com/jeremybbauer/f19e6f0985e42d82881b9ac3792647cd

hi @spacey-j,

to the problem is somewhere in here:

9:50:29 AM: 2020-10-17T16:50:29.589Z Eleventy:EleventyErrorHandler Problem writing Eleventy templates:
9:50:29 AM: 2020-10-17T16:50:29.589Z Eleventy:EleventyErrorHandler TemplateLayoutPathResolver directory does not exist for default: _includes
9:50:29 AM: `Error` was thrown:
9:50:29 AM: 2020-10-17T16:50:29.589Z Eleventy:EleventyErrorHandler (error stack): Error: TemplateLayoutPathResolver directory does not exist for default: _includes
9:50:29 AM:     at TemplateLayoutPathResolver.findFileName (/opt/build/repo/node_modules/@11ty/eleventy/src/TemplateLayoutPathResolver.js:96:13)
9:50:29 AM:     at TemplateLayoutPathResolver.init (/opt/build/repo/node_modules/@11ty/eleventy/src/TemplateLayoutPathResolver.js:61:28)
9:50:29 AM:     at new TemplateLayoutPathResolver (/opt/build/repo/node_modules/@11ty/eleventy/src/TemplateLayoutPathResolver.js:15:10)
9:50:29 AM:     at new TemplateLayout (/opt/build/repo/node_modules/@11ty/eleventy/src/TemplateLayout.js:15:24)
9:50:29 AM:     at Function.getTemplate (/opt/build/repo/node_modules/@11ty/eleventy/src/TemplateLayout.js:38:16)
9:50:29 AM:     at Template.getData (/opt/build/repo/node_modules/@11ty/eleventy/src/Template.js:219:37)
9:50:29 AM:     at async Template.getTemplateMapEntries (/opt/build/repo/node_modules/@11ty/eleventy/src/Template.js:681:16)
9:50:29 AM:     at async TemplateMap.add (/opt/build/repo/node_modules/@11ty/eleventy/src/TemplateMap.js:32:21)
9:50:29 AM:     at async Promise.all (index 1)
9:50:29 AM:     at async TemplateWriter._createTemplateMap (/opt/build/repo/node_modules/@11ty/eleventy/src/TemplateWriter.js:132:5)
9:50:29 AM: Wrote 0 files in 0.21 seconds (v0.10.0)
9:50:29 AM: 2020-10-17T16:50:29.590Z Eleventy Finished writing templates.
9:50:29 AM: 2020-10-17T16:50:29.590Z Eleventy

i’m not exactly sure what is causing the error, but i also have to ask why you are trying to deploy to netlify in debug mode?

ideally you want to perfect and polish and debug your site locally, and then only push your a finished production-grade deploy (for various reasons - not just that we bill for build minutes)

The first question has to be: does this work locally?

This general debugging advice might be helpful:

please post again if the error persists after you get it running locally!

Thanks for taking a look, Perry!

I was deploying in debug mode because I tried using Netlify’s 11ty starter, and it used that build command and is working fine. Another post in this community about using 11ty also reported that build command working for them. And I thought that if the deploy didn’t work, it would be good to have the debug info in case I needed to post on here.

I tried changing the build command to npx @11ty/eleventy in the Build Settings and in the netlify.toml file, but it still isn’t working.

You should first ensure it runs locally, I cloned your repo and ran npx @11ty/eleventy and it still results in the error
TemplateLayoutPathResolver directory does not exist for default: _includes
Maybe checkout issues on eleventy github:

for example!