GUI does not detect netlify dev --graph

I am trying out the beta of Netlify Graph, and have been unable to get to the step where I can query a connected API. When I run netlify dev --graph, my site spins up just fine and runs at http://localhost:8888. In the GUI, I’m prompted to “Open a new session in Netlify Dev” despite it indeed being open. My test site is at

I’ve tried a number of times with different repos. The build settings are correct and the site is linked to a repo, and locally the repo is linked to the site via netlify link --name nuxt-graph-test. My Netlify CLI is up to date. I’ve connected to both Stripe and Github APIs in the GUI.

I watched the Twitch deep dive (Twitch) and Jason or Sean mentioned that a link to the GraphQL sandbox should appear in the log when running netlify dev --graph, but it does not for me.

Any pointers appreciated! Excited to play with Graph.

Hey @jennie,

Based on that description, it appears as if this should work. We would pass this on to engineers to see what can be done about this.

@jennie want to make sure that I am able to reproduce the issue. What OS/CLI version are you using?

I’m using netlify-cli@9.8.3 and Mac OS 12.2.1.

Thank you - working on trying to reproduce the issue.

@jennie to make this more actionable, can you please link me to a public repository from which you are deploying your test site? I want to make sure that I am testing the exact conditions that you have.