Google rich snippets not showing up

I have a few sites on Netlify and a few on Cloudflare pages. I moved one of the sites from netlify to cloudflare and waited for google cache to clear. I found that google snippets are available but as I switched back to netlify the search results were different.

Google rich snippets tester detected my site eligible when It was on cloudflare pages or netlify. Is it due to the servers that netlify use or something else.

What am I missing?

Would you mind sharing the link?

Not my site so can’t share. I can create a replica if you want?

It’s strange that a website that’s being submitted to Google for public access can’t be shared in a forum. It’s not possible to debug without knowing the address, but sure if the replica is a copy of the same thing and has the same error, it should help.

Here is a duplicate Dopetrope by HTML5 UP

This page has passed the rich results test

UPDATE: I mistakenly gave the .netlify domain the custom domain is

Yeah so as I can see, your website seems to have the Schema setup and working fine. And as you’ve already said that the tester is also showing that the website is eligible. So, if it’s still not showing the structured data in search results, it’s probably a problem on Google’s end. From what I know, even if you have setup the data fine, it’s Google who decides whether to show it in results or not.

I think google has no problem showing the snippets of my site as I saw it myself when the site was on cloudflare but Its not now on netlify. I am just avoiding going back to cloudflare because of some features on netlify

Hey there, @helowhoa :wave:

Are you still experiencing issues here? If so, what additional debugging steps have you taken in the past five days.

Echoing what Hrishikesh stated, I think the next step would be seeing the actual site in question. If not that, then your netlify site ID so that we can search it on our end.