Git Gateway / Netlify CMS: Some collections are no longer showing since this morning


Since this morning, and on multiple websites, some collections are no longer showing in Netlify CMS. To be precise, the collections show, but they are empty.
I wonder if this is a Git Gateway issue?

  • This happens on all branches, and on several of our websites (some of them we haven’t touched in a while). I cannot give the websites urls publicly.
  • We are using GitHub
  • The is no errors in the network inspector. All .netlify/git/github/git/trees/x requests return 200 and the expected data. No obvious difference in the response headers and body between the collections that work and those that don’t.
  • I tried to remove / add Netlify Identity, add / remove the Git Gateway, reset the Git token, change the GitHub account used for the Gateway, none of these worked.

Thank you in advance,

PS: I was asked to post here by @NetlifySupport on Twitter:

Found a temporary fix: rolled back to Netlify CMS 2.10.5 which is the last version on which the problem does not occur. Switching between versions do trigger the bug.

Thank you.

Would you mind opening an issue at so it can be tracked there? Not sure if all the maintainers read the community forum.

1 Like

Ended up adding to this issue:

Let me know if you need more info,
Thank you.