Git Gateway error

Thank you so much it worked!

Thanks for the help @ansh

1 Like

Hey @ansh,
Thanks so much for sharing this solution!

1 Like

Of course! This forum has been super helpful to me so I’m glad to help where I can :slight_smile:

3 Likes

This worked for me :raised_hands: Thanks @ansh!!!

Thanks, @ansh. :hugs: I just fixed mine now with your help

thank you for saying so! Please come back again soon :slight_smile:

This was the fix for me <3

This happened to me too after renaming my repo. After multiple token reissues, cache deletion, refreshes etc the solution that worked was to unlink the repo from Netlify and then relink it.

2 Likes

i got the same [object object] error - removed all cookies and voila it works again

I had the same problem when migrating a site to another branch in another repo. After having linked the new repo, I needed to change also the branch attribute under cms in config/_default/params.yaml

1 Like

Thanks for coming back and letting us know, @aretor :netliconfetti:

Git Gateway Error: [object Object]

I had this error after migrating via CDN from netlify-cms v1 to v2 on my gatsby site and then deploying the site on the master branch. It showed up right away on the /admin page.

Opening a window in incognito resolved it for me. A pain, but shows that there was no changes to make on my deploy.

Back to the original browser, I just cleared my storage and it worked. (I think it was just Cookies)

1 Like

Okay guys, so this is info for those who are struggling with it in 2022.

Here is a list of how to:

  1. DO NOT be pissed off like me, be better than me, it does not matter that you used TEMPLATE prepared by Netlify, they have not automated its testing, so keep patience and read next:
  2. If you have free tier JUST LIKE MANY OF US, do not follow this awesome post [Common Issue] Netlify CMS & Git Gateway - Email not confirmed because IT DOES NOT HELP
  3. Go to ./site/static/admin/config.yml (exactly this path, not something else)
  4. Add the branch field to config:
backend:
  name: git-gateway
  branch: main # <------ THIS
  1. Deploy website (push the changes) & wait until it finishes
  2. Go to /settings/identity#git-gateway in Netlify admin
  3. Disable & enable git-gateway
  4. Go to website /admin (NOBODY wrote it in README, so you must suffer, but whatever)
  5. Clear website data (or manually go to localStorage and cookies and remove ALL)
  6. Hard reload the page

Should work.
If it did not work, just leave the Netlify CMS, because they do not care about you, just like this Support Engineer answerd:

If you’ve indeed tried everything, I don’t think there’s anything more anyone can suggest.

You know…

Why am I using this straightforward language, because guys if you do something, please test it first, because people use it straight by your documentation and struggle sooooo much and spend sooooo much time and then we see this:

If you’ve indeed tried everything, I don’t think there’s anything more anyone can suggest.

5 Likes

Hi @alexblbl,

I understand it may have been frustrating finding the solution, but thank you for posting the solution in this thread.

The post you quoted is from over a year old ago and not all solutions may still be valid as the CMS changes over time. I believe in that post it was being asked if they had tried everything. Additionally, the person also posted a link to a similar Git Gitway issue on the netlify-cms’ Github repo, and they continued to try and help within the thread.

Note that Netlify CMS is an open source project and we do not offer the same level of support for Netlify CMS as we do for our core Netlify features. This is mentioned here. Netlify CMS is used by thousands of users and the community does our best to assist everyone as demonstrated many times in this thread and others. Other ways to get support for Netlify CMS are listed here: Community | Netlify CMS | Open-Source Content Management System.

1 Like

Hi @Melvin,

Thanks for answering, I am feeling relief when I see somebody really cares.

From your post, I assume I did not find solution because had not found that link (where people are still having the help), well, might be, but I spent quite much time on it.

But think from my side, I saw your advertisement and solution on many conferences and videos across the web, but was not able to try, then boom, opportunity appeared and I thought “It is time for great tool”, I went to Netlify (first checked the prices and support level and agreed), I thought, well the guys know what they build I should trust them and take their template first. I took one, which was the first with the blog, it worked, cool but not enough (because I knew I need CMS built in), so I went to this awesome “one-click-hugo-cms”, which looks pretty decent with CMS support built-in, but this is where my suffer begin.

To make long story short, just be like me, try your product from a user perspective:

  1. Setup this HUGO from template
  2. Try to go and change something in the CMS

Simple steps, but they show that if you provide some products and you have a will to sell them later (when limits exceeds or users would need more features), try to do your best, this is a face of your company. Most of us will start from free tier and grow continuously, but bounce rate will persist or even increase if you will not test the things, which you provide. Because what I see: “Well, these guys did not test their code, hmmm what to expect next when I move to the next tier?”

I have experience more than 10 years and such things just matter.

I hope you will listen to me and community and just try things from our perspective and some day the god of automation will shine a star in your honor.

1 Like

hi there @alexblbl , so sorry to hear you are having frustrations you weren’t expecting. That’s never great. That said, I do want to clarify that the CMS is no longer a regularly supported product that benefits from having a paid development team that works on it, instead, it is a free and open source project that relies on volunteer to improve and support. I hear that you care about the quality of software - please do get involved and submit some PRs to fix the things you are describing! that help would be very welcome.

As such, there are always going to be some caveats to its usability. But it is still a viable solution, we feel, for sites who want an independent CMS.

If you need support, or, even better, if you want to help out in making the CMS better, here are some ways to do so:

netlifycms.org - the site houses our extensive documentation that likely contains helpful information to get you back on track.

netlify cms slack - join our friendly slack channel and chat with other cms pros to get the help you need.

GitHub Issues - think you’ve found a bug, or would like to make a feature request? Make your voice heard here. Netlify CMS is open source - PRs and other contributions are also welcome!

Stack Overflow Check StackOverflow for questions tagged “Netlify CMS” if you don’t get an answer in the Slack or the GH issues. StackOverflow reaches a worldwide audience of knowledgeable people.

Again, thanks for trying out Netlify CMS - and i acknowledge the frustration you were experiencing! I do hope it works out better for you in the future.

1 Like

this worked for me. thank you for sharing this!

1 Like

Thank you alexblb this worked for me also.

Thanks for this. I had already reissued my token and relinked my repo as seen elsewhere, and cleared my browser cache, to no avail. But your post had what I needed: My branch is main so substituting that in your example and provided location of site/static/admin/config.yml helped and I’ve been rewarded with a functioning CMS.

3 Likes

Amazing!!! Thanks a lot for your clear answer!! :pray:t2: Worked for me!

1 Like