Getting Access Denied Error

@gregraven no, that’s my “production” build that was built within Netlify.
i’m trying to access the deploy preview that Netlify says should be live at the url I posted above.
I generated the deploy preview by building locally and then using netlify deploy.

So, if I remove my _redirects file the the Deploy preview works as expected.
I then re-added my redirects file, and the deploy worked again.
This seems to have resolved the problem? No code changes were made.

@makon Excellent. That’s good to know. Glad you figured it out.

Hey there,

I’m seeing the same issue on one of my deploy previews. We run deploy previews on every PR in our repo, and usually they work fine. On this particular PR, I see the same error page listed above at the generated preview link deploy-preview-2443–

When I go to the Netlify app, and into the deploy details for this particular preveiw, and click the “Preview” button from the build page, I get sent to a different site, commit-hash– This link works just fine. I also opened another PR with the exact same commits to trigger another preview to make sure it wasn’t an issue with my code, and the preview on that PR works fine as well.

I tried removing the _redirects file and re-adding it, and that didn’t solve anything. Was there any further investigation on this issue and why it might happen? We’ve done thousands of deploys and seems like this just randomly appeared, and we’d like to be confident that our site won’t break when we deploy.

Hi, @attfarhan. To troubleshoot, we need to know the actual URL which isn’t working.

You can post that information publicly or you can private message (PM) that to one of our support staff. I’ve confirmed that PMs are enabled for your community login. Please keep in mind that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.