Home
Support Forums

Gatsby site failed to deploy: Command did not finish within the time limit

Name: pmblog.netlify.app

Dependencies:

"algoliasearch": "^4.9.0",
    "disqus-react": "^1.0.8",
    "dotenv": "^8.2.0",
    "gatsby": "^3.14.0",
    "gatsby-image": "^2.3.5",
    "gatsby-plugin-advanced-sitemap": "^1.6.0",
    "gatsby-plugin-algolia": "^0.19.0",
    "gatsby-plugin-google-gtag": "^3.3.0",
    "gatsby-plugin-html-attributes": "^1.0.5",
    "gatsby-plugin-image": "^1.3.1",
    "gatsby-plugin-manifest": "^3.3.0",
    "gatsby-plugin-offline": "^4.3.0",
    "gatsby-plugin-react-helmet": "^4.3.0",
    "gatsby-plugin-remove-fingerprints": "0.0.2",
    "gatsby-plugin-robots-txt": "^1.5.6",
    "gatsby-plugin-sharp": "^2.14.3",
    "gatsby-plugin-styled-components": "^4.3.0",
    "gatsby-remark-images": "^5.0.0",
    "gatsby-remark-source-name": "https://github.com/AnnieTaylorCHEN/gatsby-remark-source-name.git",
    "gatsby-source-filesystem": "^3.3.0",
    "gatsby-transformer-remark": "^4.0.0",
    "gatsby-transformer-sharp": "^3.3.0",
    "postcss": "^8.2.10",
    "postcss-loader": "^5.2.0",
    "prop-types": "^15.7.2",
    "react": "^16.13.1",
    "react-dom": "^16.13.1",
    "react-helmet": "^5.2.1",
    "react-instantsearch-dom": "^6.10.3",
    "react-share": "^4.4.0",
    "styled-components": "^5.2.3",
    "styled-icons": "^9.5.0"

Problem: build failed.

The last successful build was in July 2021, and the log is as below.

3:28:49 PM: Build ready to start
3:28:51 PM: build-image version: 2cee85eb7f808bf3b6e87378c5307f9411f0a332
3:28:51 PM: build-image tag: v3.8.0
3:28:51 PM: buildbot version: b7aeb2675f82192daa8545b22bebab9c3b179d0e
3:28:51 PM: Fetching cached dependencies
3:28:51 PM: Starting to download cache of 1.9GB
3:29:04 PM: Finished downloading cache in 12.98762733s
3:29:04 PM: Starting to extract cache
3:29:37 PM: Finished extracting cache in 32.331381146s
3:29:37 PM: Finished fetching cache in 45.751111136s
3:29:37 PM: Starting to prepare the repo for build
3:29:37 PM: Preparing Git Reference refs/heads/master
3:29:40 PM: Parsing package.json dependencies
3:29:40 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
3:29:40 PM: Starting build script
3:29:40 PM: Installing dependencies
3:29:40 PM: Python version set to 2.7
3:29:41 PM: Started restoring cached node version
3:29:45 PM: Finished restoring cached node version
3:29:46 PM: Downloading and installing node v12.22.2...
3:29:47 PM: Downloading https://nodejs.org/dist/v12.22.2/node-v12.22.2-linux-x64.tar.xz...
3:29:47 PM: Computing checksum with sha256sum
3:29:47 PM: Checksums matched!
3:29:49 PM: Now using node v12.22.2 (npm v6.14.13)
3:29:50 PM: Started restoring cached build plugins
3:29:50 PM: Finished restoring cached build plugins
3:29:50 PM: Attempting ruby version 2.6.2, read from environment
3:29:51 PM: Using ruby version 2.6.2
3:29:52 PM: Using PHP version 5.6
3:29:52 PM: Started restoring cached node modules
3:29:52 PM: Finished restoring cached node modules
3:29:52 PM: Installing NPM modules using NPM version 6.14.13
3:30:11 PM: npm WARN eslint-config-react-app@6.0.0 requires a peer of babel-eslint@^10.0.0 but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN express-graphql@0.9.0 requires a peer of graphql@^14.4.1 but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN gatsby-plugin-advanced-sitemap@1.6.0 requires a peer of gatsby@^2.0.0 but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN gatsby-plugin-image@1.3.1 requires a peer of gatsby-plugin-sharp@^3.0.0-next.0 but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN gatsby-remark-images@5.0.0 requires a peer of gatsby-plugin-sharp@^3.0.0-next.0 but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN gatsby-transformer-sharp@3.3.0 requires a peer of gatsby-plugin-sharp@^3.0.0-next.0 but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN ts-node@9.1.1 requires a peer of typescript@>=2.7 but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN tsutils@3.21.0 requires a peer of typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself.
3:30:11 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
3:30:11 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
3:30:11 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):
3:30:11 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
3:30:11 PM: added 1 package from 2 contributors, updated 4 packages and audited 2692 packages in 18.614s
3:30:13 PM: 294 packages are looking for funding
3:30:13 PM:   run `npm fund` for details
3:30:13 PM: found 101 vulnerabilities (84 moderate, 17 high)
3:30:13 PM:   run `npm audit fix` to fix them, or `npm audit` for details
3:30:13 PM: NPM modules installed
3:30:13 PM: Started restoring cached go cache
3:30:15 PM: Finished restoring cached go cache
3:30:15 PM: Installing Go version 1.12
3:30:15 PM: unset GOOS;
3:30:15 PM: unset GOARCH;
3:30:15 PM: export GOROOT='/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64';
3:30:15 PM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64/bin:${PATH}";
3:30:15 PM: go version >&2;
3:30:15 PM: export GIMME_ENV='/opt/buildhome/.gimme_cache/env/go1.12.linux.amd64.env';
3:30:15 PM: go version go1.12 linux/amd64
3:30:15 PM: Installing missing commands
3:30:15 PM: Verify run directory
3:30:16 PM: ​
3:30:16 PM: ────────────────────────────────────────────────────────────────
3:30:16 PM:   Netlify Build                                                 
3:30:16 PM: ────────────────────────────────────────────────────────────────
3:30:16 PM: ​
3:30:16 PM: ❯ Version
3:30:16 PM:   @netlify/build 12.26.0
3:30:16 PM: ​
3:30:16 PM: ❯ Flags
3:30:16 PM:   deployId: 60e1b7914fcd840007d87ace
3:30:16 PM: ​
3:30:16 PM: ❯ Current directory
3:30:16 PM:   /opt/build/repo
3:30:16 PM: ​
3:30:16 PM: ❯ Config file
3:30:16 PM:   No config file was defined: using default values.
3:30:16 PM: ​
3:30:16 PM: ❯ Context
3:30:16 PM:   production
3:30:16 PM: ​
3:30:16 PM: ❯ Loading plugins
3:30:16 PM:    - netlify-plugin-gatsby-cache@0.3.0 from Netlify app
3:30:16 PM:    - netlify-plugin-no-more-404@0.0.15 from Netlify app
3:30:16 PM: ​
3:30:16 PM: ────────────────────────────────────────────────────────────────
3:30:16 PM:   1. onPreBuild command from netlify-plugin-gatsby-cache        
3:30:16 PM: ────────────────────────────────────────────────────────────────
3:30:16 PM: ​
3:30:29 PM: Found a Gatsby cache. We’re about to go FAST. ⚑️
3:30:29 PM: ​
3:30:29 PM: (netlify-plugin-gatsby-cache onPreBuild completed in 12.5s)
3:30:29 PM: ​
3:30:29 PM: ────────────────────────────────────────────────────────────────
3:30:29 PM:   2. Build command from Netlify app                             
3:30:29 PM: ────────────────────────────────────────────────────────────────
3:30:29 PM: ​
3:30:29 PM: $ gatsby build
3:30:33 PM: success open and validate gatsby-configs - 0.171s
3:30:36 PM: warning Plugin gatsby-plugin-advanced-sitemap is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.0.0
3:30:36 PM: warning Plugin gatsby-plugin-advanced-sitemap is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.0.0
3:30:36 PM: success load plugins - 1.708s
3:30:36 PM: success onPreInit - 0.057s
3:30:36 PM: success initialize cache - 0.006s
3:30:37 PM: success copy gatsby files - 0.114s
3:30:37 PM: success onPreBootstrap - 0.020s
3:30:37 PM: success createSchemaCustomization - 0.079s
3:30:39 PM: success Checking for changed pages - 0.000s
3:30:39 PM: success source and transform nodes - 2.184s
3:30:40 PM: success building schema - 0.703s
3:30:40 PM: info Total nodes: 2695, SitePage nodes: 163 (use --verbose for breakdown)
3:30:40 PM: success createPages - 0.243s
3:30:40 PM: success Checking for changed pages - 0.000s
3:30:40 PM: success createPagesStatefully - 0.116s
3:30:40 PM: success Cleaning up stale page-data - 0.015s
3:30:40 PM: success update schema - 0.137s
3:30:40 PM: success onPreExtractQueries - 0.001s
3:30:42 PM: success extract queries from components - 2.194s
3:30:42 PM: success write out redirect data - 0.001s
3:30:43 PM: success Build manifest and related icons - 0.183s
3:30:43 PM: success onPostBootstrap - 0.764s
3:30:43 PM: info bootstrap finished - 14.292s
3:31:02 PM: success run page queries - 19.307s - 22/22 1.14/s
3:31:02 PM: success write out requires - 0.009s
3:31:32 PM: success Building production JavaScript and CSS bundles - 29.384s
3:31:32 PM: success Rewriting compilation hashes - 0.001s
3:31:41 PM: success Building HTML renderer - 8.656s
3:31:43 PM: success Building static HTML for pages - 2.321s - 173/173 74.53/s
3:31:43 PM: success Generating image thumbnails - 59.058s - 36/36 0.61/s
3:31:43 PM: info Generated public/sw.js, which will precache 7 files, totaling 297896 bytes.
3:31:43 PM: The following pages will be precached:
3:31:43 PM: /offline-plugin-app-shell-fallback/index.html
3:31:49 PM: success index to Algolia - 6.372s - Done!
3:31:50 PM: success onPostBuild - 6.564s
3:31:50 PM: info Done building in 80.750295926 sec
3:31:50 PM: ​
3:31:50 PM: (build.command completed in 1m 20.9s)
3:31:50 PM: ​
3:31:50 PM: ────────────────────────────────────────────────────────────────
3:31:50 PM:   3. onPostBuild command from netlify-plugin-gatsby-cache       
3:31:50 PM: ────────────────────────────────────────────────────────────────
3:31:50 PM: ​
3:32:02 PM: Stored the Gatsby cache to speed up future builds.
3:32:02 PM: ​
3:32:02 PM: (netlify-plugin-gatsby-cache onPostBuild completed in 11.8s)
3:32:02 PM: ​
3:32:02 PM: ────────────────────────────────────────────────────────────────
3:32:02 PM:   4. onPostBuild command from netlify-plugin-no-more-404        
3:32:02 PM: ────────────────────────────────────────────────────────────────
3:32:02 PM: ​
3:32:02 PM: html manifest saved for next run
3:32:02 PM: ​
3:32:02 PM: (netlify-plugin-no-more-404 onPostBuild completed in 628ms)
3:32:02 PM: ​
3:32:02 PM: ────────────────────────────────────────────────────────────────
3:32:02 PM:   5. Deploy site                                                
3:32:02 PM: ────────────────────────────────────────────────────────────────
3:32:02 PM: ​
3:32:02 PM: Starting to deploy site from 'public'
3:32:05 PM: Creating deploy tree asynchronously
3:32:05 PM: Creating deploy upload records
3:32:11 PM: 66 new files to upload
3:32:11 PM: 0 new functions to upload
3:32:14 PM: Site deploy was successfully initiated
3:32:14 PM: ​
3:32:14 PM: (Deploy site completed in 11.5s)
3:32:14 PM: ​
3:32:14 PM: ────────────────────────────────────────────────────────────────
3:32:14 PM:   Netlify Build Complete                                        
3:32:14 PM: ────────────────────────────────────────────────────────────────
3:32:14 PM: ​
3:32:14 PM: (Netlify Build completed in 1m 58s)
3:32:14 PM: Caching artifacts
3:32:14 PM: Started saving node modules
3:32:14 PM: Finished saving node modules
3:32:14 PM: Started saving build plugins
3:32:14 PM: Finished saving build plugins
3:32:14 PM: Started saving pip cache
3:32:14 PM: Finished saving pip cache
3:32:14 PM: Started saving emacs cask dependencies
3:32:14 PM: Finished saving emacs cask dependencies
3:32:14 PM: Started saving maven dependencies
3:32:14 PM: Finished saving maven dependencies
3:32:14 PM: Started saving boot dependencies
3:32:14 PM: Finished saving boot dependencies
3:32:14 PM: Started saving rust rustup cache
3:32:14 PM: Finished saving rust rustup cache
3:32:14 PM: Started saving go dependencies
3:32:16 PM: Finished saving go dependencies
3:32:22 PM: Build script success
3:32:35 PM: Starting post processing
3:32:35 PM: Post processing - HTML
3:33:00 PM: Post processing - header rules
3:33:00 PM: Post processing - redirect rules
3:33:00 PM: Post processing done
3:33:00 PM: Site is live ✨
3:35:18 PM: Finished processing build request in 6m26.540234972s
Docs
Pricing
Support
News
Terms
Β© 2021 Netlify

Since then what I did was add a new post as before, I pushed the code to github and it triggered a build but failed. The reason was like the title. Since then, I have done some digging and googling, and I have:

  1. triggered a new build without cache
  2. updated my npm packages (those that aren’t breaking changes)
  3. I have installed a plug called gatsby-plugin-remove-fingerprints and it seems to be suggested by Netlify according to this page.

Still… things are not working and I am drying to find out why. Here is the latest log after I’ve done the things above.

5:34:38 PM: Build ready to start
5:34:39 PM: build-image version: c6001ed68662a13e5deb24abec2b46058c58248a
5:34:39 PM: build-image tag: v3.9.0
5:34:39 PM: buildbot version: f650485c830eb31597911322420b99299a4303b8
5:34:39 PM: Fetching cached dependencies
5:34:40 PM: Failed to fetch cache, continuing with build
5:34:40 PM: Starting to prepare the repo for build
5:34:40 PM: No cached dependencies found. Cloning fresh repo
5:34:40 PM: git clone https://github.com/AnnieTaylorCHEN/petiteandminimalblog
5:34:47 PM: Preparing Git Reference refs/heads/master
5:34:48 PM: Parsing package.json dependencies
5:34:48 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
5:34:49 PM: Starting build script
5:34:49 PM: Installing dependencies
5:34:49 PM: Python version set to 2.7
5:34:50 PM: Downloading and installing node v12.22.6...
5:34:50 PM: Downloading https://nodejs.org/dist/v12.22.6/node-v12.22.6-linux-x64.tar.xz...
5:34:50 PM: Computing checksum with sha256sum
5:34:50 PM: Checksums matched!
5:34:53 PM: Now using node v12.22.6 (npm v6.14.15)
5:34:53 PM: Started restoring cached build plugins
5:34:53 PM: Finished restoring cached build plugins
5:34:53 PM: Attempting ruby version 2.6.2, read from environment
5:34:54 PM: Using ruby version 2.6.2
5:34:54 PM: Using PHP version 5.6
5:34:54 PM: Started restoring cached node modules
5:34:54 PM: Finished restoring cached node modules
5:34:55 PM: Installing NPM modules using NPM version 6.14.15
5:52:49 PM: > sharp@0.28.1 install /opt/build/repo/node_modules/gatsby-plugin-manifest/node_modules/sharp
5:52:49 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
5:52:51 PM: sharp: Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.10.6/libvips-8.10.6-linux-x64.tar.br
5:52:52 PM: > sharp@0.28.1 install /opt/build/repo/node_modules/gatsby-transformer-sharp/node_modules/sharp
5:52:52 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
5:52:53 PM: sharp: Using cached /opt/buildhome/.npm/_libvips/libvips-8.10.6-linux-x64.tar.br
5:52:54 PM: > sharp@0.27.2 install /opt/build/repo/node_modules/sharp
5:52:54 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
5:52:56 PM: info sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.10.5/libvips-8.10.5-linux-x64.tar.br
5:52:58 PM: > core-js@2.6.12 postinstall /opt/build/repo/node_modules/babel-runtime/node_modules/core-js
5:52:58 PM: > node -e "try{require('./postinstall')}catch(e){}"
5:52:58 PM: > core-js@3.18.0 postinstall /opt/build/repo/node_modules/core-js
5:52:58 PM: > node -e "try{require('./postinstall')}catch(e){}"
5:52:58 PM: > core-js-pure@3.18.0 postinstall /opt/build/repo/node_modules/core-js-pure
5:52:58 PM: > node -e "try{require('./postinstall')}catch(e){}"
5:53:00 PM: > gatsby-telemetry@2.14.0 postinstall /opt/build/repo/node_modules/gatsby-plugin-page-creator/node_modules/gatsby-telemetry
5:53:00 PM: > node src/postinstall.js || true
5:53:00 PM: > gatsby-telemetry@2.14.0 postinstall /opt/build/repo/node_modules/gatsby-recipes/node_modules/gatsby-telemetry
5:53:00 PM: > node src/postinstall.js || true
5:53:00 PM: > gatsby-telemetry@1.10.1 postinstall /opt/build/repo/node_modules/gatsby-telemetry
5:53:00 PM: > node src/postinstall.js || true
5:53:00 PM: > gatsby-telemetry@2.14.0 postinstall /opt/build/repo/node_modules/gatsby/node_modules/gatsby-telemetry
5:53:00 PM: > node src/postinstall.js || true
5:53:00 PM: > mozjpeg@7.0.0 postinstall /opt/build/repo/node_modules/mozjpeg
5:53:00 PM: > node lib/install.js
5:53:01 PM:   βœ” mozjpeg pre-build test passed successfully
5:53:01 PM: > pngquant-bin@6.0.0 postinstall /opt/build/repo/node_modules/pngquant-bin
5:53:01 PM: > node lib/install.js
5:53:01 PM:   βœ” pngquant pre-build test passed successfully
5:53:01 PM: > gatsby-cli@3.14.0 postinstall /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli
5:53:01 PM: > node scripts/postinstall.js
5:53:01 PM: > gatsby@3.14.0 postinstall /opt/build/repo/node_modules/gatsby
5:53:01 PM: > node scripts/postinstall.js
5:53:04 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
5:53:04 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
5:53:04 PM: added 2701 packages from 1080 contributors and audited 2705 packages in 1089.003s
5:53:07 PM: 327 packages are looking for funding
5:53:07 PM:   run `npm fund` for details
5:53:07 PM: found 14 vulnerabilities (9 moderate, 5 high)
5:53:07 PM:   run `npm audit fix` to fix them, or `npm audit` for details
5:53:07 PM: Execution timed out after 18m18.345380081s
5:53:07 PM: Error running command: Command did not finish within the time limit
5:53:07 PM: Creating deploy upload records
5:53:07 PM: Failing build: Failed to build site
5:53:07 PM: Failed during stage 'building site': Command did not finish within the time limit
5:53:07 PM: Finished processing build request in 18m27.78598496s

What should I do from here? Would appreciate some help, thank you!

Hi again, I’ve resolved to manual deploy to at least update my site, and it was successful. For anyone who wants to know follow this page:
https://docs.netlify.com/cli/get-started/

However, I do want to know what caused the above problem and I want to fix it so in the future I could have my smooth CI/CD back.

Hi @AnnieTC,

The builds have a time limit of 15 mins by default - yours went over that limit and thus it was force terminated. We could increase the build timeout, however that requires you to add a card to your account. The upgrade it free, though. Let us know if you’d like for us to bump it.

Thanks for the nice offer. I might consider doing that.

Can I ask WHY it exceeds built limit time? It used to be built in 6m+. I just added one post, how come now it would require 15m+ to build? Also why is it not fetching cached dependencies? How long do you keep that? If I push at least once a month will it be alright? At least that’s what I used to do and I never had problem, but this time it’s almost close to three months that I haven’t pushed any commit to this project.

hey annie,

i have a few more questions - can you tell us a bit more about the one dependency here:

"gatsby-remark-source-name": "https://github.com/AnnieTaylorCHEN/gatsby-remark-source-name.git"

nothing else about your package.json really stands out but this one did seem a little unusual. overall, the fact that it is taking a really long time (20minutes) to load your node_modules is a bit of a red flag.

if that :point_up: dependency is the culprit, it would also explain why your site is building much faster on local.

it might be interesting to delete your local node_modules folder and see if it takes a long time to build on local from scratch. it might also be interesting to delete that dependency from your package.json and see if that makes your build on netlify run a lot faster.

let us know what you find out!

Hi @AnnieTC,

I can’t comment on why the timing has increased as such. But yes, the cache might be deleted over time. There’s no fixed time as it might depend on a few other stuff, but in most cases it would get deleted in a timespan like 3 months.

Hello Perry,

Yeah I know that self-hosted package doesn’t seem to do much, although without it my repo has some problems… such as individual posts aren’t built properly. I am still trying to figure out why. :sweat_smile:

Otherwise usually when you delete Node_modules, reinstall everything, my current repo built in 48 seconds or so.

1 Like

Alright, good to know. I will try to refactor as Perry suggested to see if things improve and report back.

1 Like

Hello,

I’ve done:

  1. removed my self-hosted package
  2. refactored the code to work with Gatsby v3
  3. updated other packages that doesn’t work with v3

then I pushed the code. BUT it still took a long time to build and I can see it’s the no cache issue like before. Local build is quite fast.

4:46:48 PM: Build ready to start
4:46:50 PM: build-image version: c6001ed68662a13e5deb24abec2b46058c58248a
4:46:50 PM: build-image tag: v3.9.0
4:46:50 PM: buildbot version: 2cc7c0ccf754e7f302de1daa4d80d9968804770c
4:46:50 PM: Fetching cached dependencies
4:46:50 PM: Failed to fetch cache, continuing with build
4:46:50 PM: Starting to prepare the repo for build
4:46:51 PM: No cached dependencies found. Cloning fresh repo
4:46:51 PM: git clone https://github.com/AnnieTaylorCHEN/petiteandminimalblog
4:46:57 PM: Preparing Git Reference refs/heads/master
4:46:58 PM: Parsing package.json dependencies
4:46:58 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
4:46:59 PM: Starting build script
4:46:59 PM: Installing dependencies
4:46:59 PM: Python version set to 2.7
4:47:00 PM: Downloading and installing node v12.22.6...
4:47:00 PM: Downloading https://nodejs.org/dist/v12.22.6/node-v12.22.6-linux-x64.tar.xz...
4:47:00 PM: Computing checksum with sha256sum
4:47:00 PM: Checksums matched!
4:47:02 PM: Now using node v12.22.6 (npm v6.14.15)
4:47:02 PM: Started restoring cached build plugins
4:47:02 PM: Finished restoring cached build plugins
4:47:02 PM: Attempting ruby version 2.6.2, read from environment
4:47:04 PM: Using ruby version 2.6.2
4:47:04 PM: Using PHP version 5.6
4:47:04 PM: Started restoring cached node modules
4:47:04 PM: Finished restoring cached node modules
4:47:04 PM: Installing NPM modules using NPM version 6.14.15
5:00:55 PM: Canceling deploy

can you upgrade to allow a bit longer time? Then I will see if problem still remains. I have updated the card info there. Thanks!

Hey there, @AnnieTC :wave:

I have gone ahead and increased the build timeout limit to 30 minutes for your account.

Additionally, I think this site optimization resource could be helpful for you:

Let us know if you have any lingering questions!

Hi there,
I just re-triggered last canceled build and now it was successful.

I attached this for reference:

11:23:50 AM: Fetching cached dependencies
11:23:50 AM: Failed to fetch cache, continuing with build
...
11:55:09 AM: Finished processing build request in 31m19.755416618s

It was extremely long than usual… but I will read the articles to learn more. I hope next time it won’t end up like this long though.

2 Likes