Free Plan Website Size Limit


Does Netlify free plan allows only sites which weights up to 100MB per site ? I don’t see this condition on the website, but one of the developer working on open-source project told me. However, he also told me he was able to upload a website which weights 110MB, so it must be an issue with Netlify API. Is that true ?


1 Like

Hi Ajeet,

there generally isn’t a limit on the size of our free tier sites per se, although there are some practical limits - you can’t reliably upload large files using our CLI, for example:

Can you provide a bit more information as to what you are trying to accomplish and how you are deploying your site?

1 Like

Hi @perry

There is this open-source project Publii to create static html site. It has inbuilt frontend option to push the files to netlify. It uses site id and netlify token. Below is the screenshot to fill the details of netlify site.

Can you please help.

It sounds like you probably have a good amount of either images or videos, maybe even a lot of PDFs. If you do I would try using Git LFS for the larger files.

A couple of posts have good amount of screenshots. No pdfs or videos. Actually the fundamental thing I wanted to know if the website size is the restriction if I use the API ( the developer of the Open-source project is using).

hi ajeet, we are looking into this and will get you a more information on this when we can, thanks for your patience.

Thanks for your patience while we tracked it down. There is no intended size limitation in normal use, but in case you try to upload a file with a newline in the name, you hit an unintended area of the code where we do check your total deploy size and output an error about 100MB limitation.

So, don’t do that and there is no site size limit :slight_smile:

1 Like

@perry @fool Thanks so much. I am sharing this conversation link to the developer , and will update in this thread in some hours.
Thanks again

1 Like

Hi @fool @perry
Thanks for your time. Since this is an open-source project, that’s why I am following up with you guys…Just to inform you, here is what the developer has to say, “…That’s weird, because we are not uploading files with newline in the name. The problem must lie somewhere else. I suppose that it can be connected with images contents as when your website is processed by our improved thumbnails regeneration engine (will be available in the next version of the software) then all is uploading correctly. But in fact it still looks like Netlify API error.”

Do you think there might be any issue with the images ? But the manual upload works fine.

@ajeet - can you get your friend to make themselves an account here and talk to us personally so we don’t have to relay information through you? might be more efficient :slight_smile:


I have analysed this issue on our side and it seems that the Netlify API has an issue with uploading images.

When I have tried to upload the original website provided by @ajeet, then the upload process returned error with maximum size.

After regenerating thumbnails the issue is gone.

The only files which has been modified was images as other files has been the same.

How long was the deploy taking before you received the error? Do you have a deploy ID for the failed deploy or a link to it’s page in our UI (if it showed up there at all)? We need that information to find it in our logs.

Sorry for delayed response.
Here is the website I am hosting with Netlify [REMOVED LINK]
What is happening, the site gets deployed and synced for the first time, and thereafter the dashboard keeps showing UPLOADING message. But when I upload the files manually with some modifications, the site gets updated, But with API it keeps showing Deploying.

When that happens during an API deploy, it is probable that we have not received all the files we expect from your digest listing.

This article describes the steps including the call you’d make to understand what we think is still “missing”:

Thanks :slight_smile: This will be helpful.

I ran into the same issue with Publii. Even after regenerating the thumbnails, the problem persists.

Since this deploy is initiated entirely from Publii, you’ll probably want to ping their tech support - all we can tell is that they aren’t sending all the files and they’ll have to help with the fix.

Well, what you are saying is that Publii is not sending all the files, correct? Then at least Netlify API should report this error, and not say “Storage quota exceeded”, which does not accurately describe the problem. So, in my opinion, there’s also an aspect which Netlify should look at?

Sure, that is a bad error message, I agree, I’ll get a bug filed on that.

1 Like

Good news, folks! We’ve removed this limitation. Please let us know if you see it in the future.