Forms Notifications are not sending email notifications

Hi @fool, I seem to be having the same issue. My form submission notifications were working as expected until a month ago. I see the submissions in my dashboard.
My Netlify site name is: pascalevermont and the API ID: 4c4ad516-cb0f-456a-8e8a-c9b8f18af0b4

Thank you

@perry @fool Hoping to hear back from someone on the support team regarding this. Thanks!

Hi, @NeversSync. There are three email addresses configured to receive submissions form emails. Two of those were blocked due to “hard bounce” replies. I’ve removed the block now from two blocked emails.

I’ve confirmed a successful delivery to the previously blocked emails with a test form submission also.

If there are other questions or concerns, please let us know.

Working! Thank you very much.

1 Like

I too am having inconsistent notifications with a site that I built for a client at Phenyxcap.com. When I submit the form emails are going to tech@phenyxcap.com, but not consistently to info@phenyxcap.com. Any ideas why this would be the case? Any help would be great!. Thanks, Jeff.

Hi, @jkinley. We received an email delivery failure for info@phenyxcap.com on 2021-02-21 at 20:42:32 UTC. It was a permanent delivery failure - often referred to as a “hard bounce”.

To comply with anti-spam policies and regulations we stop send emails to email addresses when a hard bounce is received. The hard bounce add the email address to a deny list to prevent future emails from being attempted.

I’ve removed this email address of the hard bounce list now and future emails will be attempted again for info@phenyxcap.com. If you still don’t receive for notifications to this email address now, please let us know.

1 Like

Thank you. Seems to be working now.

1 Like

Hi, i’m having the same problem with bonjour@atelierlilicolibri.fr.
i don’t know why i can’t receive notifications and if it is the “hard bounce” problem what am i doing wrong ?

Thanks

Hi Luke, could you check nico@onecastaway.de for me please, I think I’m having the same problem and it maybe have been caused while waiting for DNS to propagate on that domain.

hi, I had not made the connection but it seems that it is the same thing. i’ve just changed my DNS config. Could somebody do something for me/us ?

Hi, @zb2oby. I checked for that email address on the bounce list but it wasn’t there.

I believe you are not receiving emails for that email address because you have no email service configured for your domain:

$ dig atelierlilicolibri.fr MX

; <<>> DiG 9.10.6 <<>> atelierlilicolibri.fr MX
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2608
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;atelierlilicolibri.fr.		IN	MX

;; AUTHORITY SECTION:
atelierlilicolibri.fr.	1793	IN	SOA	dns1.p05.nsone.net. domains+netlify.netlify.com. 1617724557 43200 7200 1209600 3600

;; Query time: 25 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue Apr 06 18:47:31 PDT 2021
;; MSG SIZE  rcvd: 131

There are zero MX records for this domain and I’m not aware of any way for email to be successfully delivered without MX records.

I think the section of this support guide labeled “I did not copy my records before switching name servers and my email (or other service) stopped working. How do I fix this?” may have the solution for your issue.

If there are any questions about either solution in the support guide above, @zb2oby, please let us know and we will be happy to answer.

For the email address you listed, @darkmekker, it was on the bounce list and I have removed it now. Your email notifications should work now and if not, please reply here anytime.

Hi, Thanks for reply. I don’t understand. It is a mailbox provided by IONOS. i have another site in netlify with the same form and globally the same configuration and i can receive notifications for it in the associated mailbox.
Moreover, i’ve made a test a month ago for bonjour@atelierlilicolibri.fr and i received notification in this mailbox. so i don’t understand why it does not works anymore.

Hi, @zb2oby. Here are the facts:

  1. MX records are required for email delivery to work.
  2. Your domain has no MX records currently, as proven by the DNS lookup below:
$ dig atelierlilicolibri.fr MX

; <<>> DiG 9.10.6 <<>> atelierlilicolibri.fr MX
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37614
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;atelierlilicolibri.fr.		IN	MX

;; AUTHORITY SECTION:
atelierlilicolibri.fr.	1799	IN	SOA	dns1.p05.nsone.net. domains+netlify.netlify.com. 1617724557 43200 7200 1209600 3600

;; Query time: 51 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Wed Apr 07 00:05:46 PDT 2021
;; MSG SIZE  rcvd: 131

I queried for the MX records above and the SOA record is returned instead. (DNS servers return SOA records when the requested record is missing.) This proves you have no MX records for your domain and this is why your email for that domain isn’t working.

To summarize, your email service simply isn’t configured - at all. I sent you a link to the two different ways to fix this, the link below:

https://answers.netlify.com/t/support-guide-how-do-i-migrate-a-domain-to-netlify-dns-with-zero-downtime/3397#heading–email-stopped-working

If there are questions about either of those two solutions, please let us know.

Ok. it works now. in fact my other site was pointing on a .fr and form on a .com. That is why it was working for it without any MX configuration but no for my new one.
this one have both mail and site pointing on the .fr domain and it need an MX record on the netlify side. It was not very clear at the begining for me but now, thanks to you, it is ok !

1 Like

Hi, @luke.

I believe I may also be dealing with the bounce list problem. I’ve received them previously but managed to disrupt my email yesterday which I believe may have caused this problem.

Can you check for shea@snktechnologies.com and/or info@snktechnologies.com?

Thanks!

Hi, @shea. I do see “soft bounces” for both email addresses in the last 48 hours. The most recent on the second email address above on Apr 14, 2021 at 4:41 am PDT (UTC-07:00).

Soft bounces are not permanent failures and I did not find either email address on the deny list. Would you please test another form submission now?

Thanks, @luke! It seems to be working now.

1 Like

Hi, @luke I think we are having the same issue with sales@frontlineremovals.com.au and dale@frontlineremovals.com.au.

Hope you can help us out too.

Cheers

Hi, @phiranno-designs. For sales@frontlineremovals.com.au, yes, this email address was on the “hard bounce” list and has been removed now. It looks like the hard bounce occurred Jun 8, 2021 at 7:47 pm PDT for that email address.

For dale@frontlineremovals.com.au, however, I’m showing that we are successfully delivering to emails to that email address. I show five successful emails for that email address today June 13th ( and all emails are for form submissions).

If you don’t see the emails for this second email address, we recommend reaching out to the technical support for your email service to find out why.

If there are other questions about this, please let us know.

1 Like

Thanks @luke I think thats fixed the problem for us.