Home
Support Forums

Form Submissions missing submitted data and forces re-submit

Hey guys,

I have looked through the support and community forms and cannot find a use case that quite reflects what I’m running into.

I am building a single HTML page personal portfolio site using Shuffle.dev and Tailwind CSS.

I have a newsletter sign up form in two locations on the page (both locations have identical code)

Live Site: adrianwaldron.com

Here’s the code:

              <div class="w-full lg:w-2/5">
                <form name="newsletter" method="POST" action="/" data-netlify="true">
                  <div class="max-w-md lg:max-w-sm mx-auto flex flex-wrap items-center">
                    <label>Email:
                      <input class="flex-grow py-3 px-4 mr-4 text-xs rounded leading-loose" type="email" placeholder="example@adrianwaldron.com">
                    </label>
                    <button class="flex-none py-2 px-6 rounded-t-xl rounded-l-xl bg-pink-600 hover:bg-pink-700 text-white font-bold leading-loose transition duration-200" type="submit">Follow Me</button>
                  </div>
                </form>
              </div>

When I submit the form, first of all, the email notification I have setup does not display the email field. Secondly, post submission, if I refresh the page it asks me to re-submit the form.

I’m looking to resolve both of these issues.

Also, I should clarify - I am definitely not a developer.

Thanks in advance for the help!

Hi there, @Adrian_Waldron :wave:

Welcome to the Forums! Developer or not, this is a great question.

I know you said you looked through some other use cases. Have you already read through our Support Guides as well? This Support Guide is the first port of call to debug form related issues, so I always like to check that folks have seen it.

If you have read that and are still having problems, please provide the information we request at the bottom of the guide. This includes:

  1. The URL of your deployed html form. In case you have a javascript form, we need to literally be linked to the html version you’ve deployed, as mentioned above (look for “ pure javascript form ”)
  2. The form name that you’ve set and that shows in our UI, for both forms.
  3. Any errors or logs from the Netlify build logs, dashboard or browser developer console
  4. Description of anything you have tried that did or didn’t help or make things better/worse
  5. Your project repo, if public

Lastly, I know you mention you have an identical form in two places on your site. Are both experiencing the same issue? Let us know!