Home
Support Forums

Form Fields not submitted

Hi guys,

I’m having trouble setting up a form on my Hugo site correctly. The site in question is this one.

I’ve followed the help document this post and several other tutorials that I found on the internet.

My form is correctly set up IMO (even my button has a name tag :slight_smile: ):

            <form name="Kontakt" method="POST" data-netlify="true" netlify-honeypot="bot-field" action="/success/">
                <div class="row">
                    <div class="col-sm-6">
                        <div class="form-group">
                          <label>Name:</label>
                            <input name="Name" type="text" class="form-control" required>
                        </div>
                    </div>
                    <div class="col-sm-6">
                        <div class="form-group">
                            <label>E-Mail-Adresse:</label>
                            <input name="Email" type="text" class="form-control" required>
                        </div>
                    </div>
                    <div class="col-sm-12">
                        <div class="form-group">
                          <label>Ihre Nachricht:</label>
                            <textarea name="Nachricht" class="form-control" required></textarea>
                        </div>
                    </div>
                        <div class="col-sm-12 text-center">
                         <button name="button" type="submit" class="btn btn-template-main"><i class="far fa-envelope"></i>Nachricht senden</button>
                    </div>
                </div>
            </form>

Everything seems to be working fine, I get the success page and a submission shows up in the admin panel, but it’s empty…

Could you please give me a hand?

Thanks and have a good one!

Edit: doodanroo has the same problem here.

1 Like

Same problem with my site. I started a thread already, can someone help us with this, please.

I have 4 forms on my sites and only 2 of them are working and receiving forms with data.

Jep, I’ve seen your thread after posting my issue… Will link in parent :slight_smile:

1 Like

I fixed it – you can read my answer here:

threads can be closed I think :slight_smile:

The documentation seems out of date:

Code an HTML form into any page on your site, add data-netlify="true" or a netlify attribute to the <form> tag, and you can start receiving submissions in your Netlify site admin panel.

It should read:

Code an HTML form into any page on your site, add netlify attribute to the <form> tag, and you can start receiving submissions in your Netlify site admin panel.

Thank you so much for sharing your solution with us, @js32 . I will share your feedback with our Documentation team as well.

1 Like

Hi @hillary, any update on this? Was ist a bug or do the docs need to be updated?
Thanks :slight_smile: J~

Hey there, @js32

Thanks for following up! One of our Support Engineers tested this, and data-netlify="true" still works in the forms. The docs do not need to be updated at this time. It sounds like something else may have been at play here. That being said, I am glad you found a solution that worked for your case!