Flatmarket fails at deploy

Required data:

Netlify site name: gifted-roentgen-22efff
Build problem? Indeed, providing logs in pastebin.
I’m following this guide (yeah I know it’s a bit old…)

Here is my flatmarket.json pastebin.com/DqkqFUVv

My project is in Visual Studio Code

I have a .gitignore


My repository in Github is private (I guess it won’t affect the build) but it’s more or less based in this one which is the original: github.com/christophercliff/flatmarket

I just run npm install, then I run this command which opens up a web server listening on port 8000.

.\node_modules.bin\flatmarket .\src\flatmarket.json --component .\node_modules\flatmarket-theme-bananas\index.jsx --stripe-secret-key sk_test_MYSECRETKEY --dev

You’ll probably notice that I’m running the command with backslashes, that’s because I’m using Windows 10 right now.

Locally it works, here is my local build log: pastebin.com/JRL2f5ir

Navigating to https localhost :8000 it just works.
To stop the server I can just control+c the terminal.

The part of the tutorial I’m struggling with is this one:

Step 5: Configure Your Settings

You will notice that configure deploys is slightly different in the current Netlify.

1st configuration:

Build command: node_modules/.bin/flatmarket ./src/flatmarket.json --component node_modules/flatmarket-theme-bananas/index.jsx --stripe-secret-key sk_test_SECRETKEY --dev
Publish directory: build

This is almost the same command I use in my local build but with normal slashes (/) instead of backslash ().

Here is the deploy log: pastebin.com/TtwPnzcq
It says building and after 30 minutes it fails due to timeout.

2nd configuration (same command as in the tutorial):

Build command: flatmarket --component ./node_modules/flatmarket-theme-bananas/index.jsx
Publish directory: build

This just fails with this error

ReferenceError: Unknown plugin “/opt/build/repo/node_modules/flatmarket-cli/node_modules/babel-plugin-transform-react-jsx” specified in “base” at 0, attempted to resolve relative to “/opt/build/repo/node_modules/flatmarket-theme-bananas”

This is the log for the second deploy configuration: pastebin.com/5KDUT1mh

I tried multiple combinations, but it doesn’t seem to deploy.

I really hope I can get some support from you guys, thanks for your work.

hey there,

thanks for reaching out. Unfortunately, that tutorial is too old for us to really have the bandwidth to legacy support, I am afraid.

There definitely may be someone in the forums who had thoughts on this for you, but as the author no longer works for Netlify, and our entire platform has changed substantially since then, we unfortunately don’t have the bandwidth to troubleshoot this. Sorry, I wish we had better news!