First time deploy question: how to set my Base Directory?

I need advice to debug deploy Netlify App

:thinking: :stuck_out_tongue_closed_eyes:

First of all totally new here and to Netlify Continuous build! My site works on Local, the node modules are being ignored, I do have a .toml file. here: sveltekit-with-tailwind2/netlify.toml at main · fourwhitesocks/sveltekit-with-tailwind2 · GitHub It obviously has something to do with my Base Directory … which I had no idea what to put; so I called it the same as the ‘root’ of the directory! I went thru the support guides first so apologies upfront :confused: Any guidance is appreciated!!

Netlify url: Netlify App

Log file: http://prntscr.com/13oeyb0

:thank_you:

Thank you! Amy - fourwhitesocks

hi there, could you pop a screenshot of your current build settings please?

@perry, here’s the screenshot you need:

@Fourwhitesocks, from the looks of it (your repo), your base directory should be empty. You seem to have your websites files in the root of your repo, thus you can safely leave the base directory empty.

Ok, great I wondered if that might be able to be empty!
Here ya go!
image

It might be something else then because I think I tried it when it was empty first and it still failed!

Thank you so much!

I can see that now you’ve set the base directory empty, however you still have the value set in your netlify.toml file. You need to delete the value from there too.

… and I was just gonna ask if I should delete it from there too; I will give it a shot!

Thank you!!!

Uggg looks like something else now…

:woozy_face:

New log file here: Netlify App

My node version is v14.15.1
My npm version is 6.14.8

12:26:13 AM: npm ERR! notsup Unsupported engine for @sveltejs/kit@1.0.0-next.111: wanted: {“node”:"^12.20 || ^14.13.1 || >= 16"} (current: {“node”:“12.18.0”,“npm”:“6.14.4”})
(Netlify App)

You need a newer Node Version. This guide would help: Manage build dependencies | Netlify Docs

Ok … even tho my node version is 14.15.1? ?

Thank you!

How have you set this? I don’t see environment variable or .nvmrc with the required version.

So that is just the node and npm version on my machine, and I must be missing something :confused: that is what gets installed when I run npm install…

Did you try to follow the link I mentioned above?

I’m looking at that right now… I see it’s an ENV issue. I will need to figure that out too. Would love to see an example; sorry some of this node stuff with the versions and all is new to me too.

:thinking:

Here’s a guide on different ways to set Environment Variables on Netlify: Build environment variables | Netlify Docs.

It would look something like this:

The value node means Netlify will always use the latest version of Node (not recommended). You can set any specific version, or even any major version. For example, if you set only 14 as the value, Netlify will use the latest version in 14.x.x.

OH ok gotcha, and this build on Netlify is asking for something between 12.20 and 14.13.1 and so as per your recommendation 14 will be fine then correct? If that is the case where did it come up with what it has now by default?

~Amy

From the error message, it looks like you can even use Node 16, but we recommend keeping the version same as your local system to it gets easier to debug.

This line mentions the current version.

Node: 12.18.0
npm: 6.14.4

OH ok! I see that now >= 16 duh ok;

…but where is it getting what it has now I don’t understand that part.

Getting closer!!

https://app.netlify.com/sites/hopeful-ritchie-1e94c8/deploys/60b68e3b6114c60d75f6ffa9

** I was missing a package!; that has been fixed.
Here is my most recent Log file now: Netlify App

I have solved my original question so I will mark this as resolved and open a new thread. I still cannot get it to Deploy properly but I did figure out the answer to my original question !

Thank you so much!