Home
Support Forums

Firebase admin install error

My firebase admin is not installing in netlify deployment but my netlify dev in local pc works fine

https://hastebin.com/icitasomix.sql

My app name jovial-spence-c10d48

Hi @shreejoy,

I’m not seeing @firebase/app-compat - npm or firebase - npm in your package.json here: MCQ-Schedule/package.json at main · shreejoy/MCQ-Schedule · GitHub.

You need to add it.

As per npm docs it mentions this is an internal package to only used by firebase package. @firebase/app-compat - npm

Ok got it.

Lemme try to add firebase package and deploy

But the point is netlify local works fine

Because you probably have the package installed locally already - but since the package doesn’t exist in package.json, Netlify doesn’t know to install it.

if you delete your node_modules folder, run npm i and then netlify dev, you’d probably face the issue locally too.

Thank you for your prompt response. My issue is solved but I will confirm you about your response

As I remembered deleting node modules and then re installing. It worked fine. But I need to confirm if any chance I had installed firebase as my global package but that is a least of chance.