File Collections Not Showing In CMS

I’m trying to get a file-based collection working, that will allow me to edit some data files from my site.
Here’s a snippet of what I have, under collections:

  - name: "data"
    label: "Data"
      - name: "company"
        label: "Company"
        file: "data/company/links.yml"
        extension: "yml"
          - name: "links"
            label: "Links"
            widget: "list"
              - {label: "Name", name: "name", widget: "string"}
              - {label: "Link", name: "link", widget: "string"}

And the yaml file, for now:

  - name: 'About'
    link: '/about'

In the CMS, “Data” shows under my “Collections”, but that area is blank. How can I show and edit “Links”?

I ran a test site with your code from above and it worked. I suspect your issue is either:

  1. The file path data/company/links.yml doesn’t match the actual file path in your remote repo, or
  2. The rest of your CMS config that wasn’t pasted above contains an error, perhaps configured for a branch that doesn’t have the file?