Failure to instal @netlify/plugin-nextjs

i keep running into this error:npm ERR! code 1
npm ERR! path C:\Users\HP\Desktop\Work Folder\upwork-assessment\node_modules\ipx\node_modules\sharp
npm ERR! command failed
npm ERR! command C:\WINDOWS\system32\cmd.exe /d /s /c (node install/libvips && node install/dll-copy && prebuild-install) || (node install/can-compile && node-gyp rebuild && node install/dll-copy)
npm ERR! sharp: Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.14.5/libvips-8.14.5-win32-x64.tar.br
npm ERR! sharp: Please see sharp - High performance Node.js image processing for required dependencies

npm ERR! sharp: Installation error: Request timed out

To install and configure the Next.js plugin on Netlify, you need to follow these steps:

  1. Include a Netlify configuration file which references Netlify’s Next.js plugin when you’re using managed hosting. You can see an example here.
  2. Netlify fully supports Next.js server-side features. If you’re using any of these, make sure that the build command does not include statically exporting your site (i.e. do not use next export).
  3. The typical build settings are as follows. They differ depending on how your site is generated.
  • For apps that use server-side rendering and Next.js Runtime:
    • Build command: next build
    • Publish directory: .next
      I strong encourage you to checkout the documentation below for your use case.

Thanks Sam, you’ve been really helpful.