Home
Support Forums

Failed to persist: API_ERROR: Not Found

Having problems accessing the ability to edit/create blog posts on a new site.

The default subdomain is tolksblog.netlify.app .
The primary domain is tolks.me

Every time and I try and update/create a blog I am hit with the API_ERROR referenced above. I have followed all the prerequisite steps and have github connected with no problems pushing updates and the domain updating so I’m a bit of a loss as to why the /admin/ will not work. When accessing it I can’t see the default blogs as well if that clear anything up. I have tried unconnected and reconnecting and creating new tokens many times and am not a member of any organizations that would need access as the default solution I searched for suggested so any help/suggestions would be greatly appreciated.

Thanks!

@tolks Welcome to the Netlify community. The first thing I would do in your situation is get the DNS straightened out. You have delegated two different sets of name servers for your custom domain.

|===================== whois name server for ====================
| -------------------------- tolks.me --------------------------
Updated Date: 2021-06-11T02:03:15Z
Name Server: DNS1.P03.NSONE.NET
Name Server: DNS2.P03.NSONE.NET
Name Server: DNS3.P03.NSONE.NET
Name Server: DNS4.P03.NSONE.NET
Name Server: NS01.SQUARESPACEDNS.COM
Name Server: NS02.SQUARESPACEDNS.COM
Name Server: NS03.SQUARESPACEDNS.COM
Name Server: NS04.SQUARESPACEDNS.COM
|================================================================

See the documentation here:

1 Like

Hey Greg, thanks for the quick response! I thought that might be the problem and wanted to connect Netlify DNS but get this error when I tried on initial setup.

@tolks Then you’ll need to fix that first.

1 Like

I believe it’s solved now and the nameservers are only dns1-4 assigned as custom domains. I’m still getting the same error and unable to see the netlify custom nameservers to input in the custom domains. Everything else is working fine as well so still a little confused as squarespace requires connecting to at least 2 custom domains but while that is the case netlify doesn’t display the custom domains that I would switch to. Hopefully that makes sense and again appreciate the help.

@tolks No, I don’t understand that explanation even a little. Sorry. I see that you’ve made some changes, but if you eliminated one of your sets of name servers then we’ll have to wait until your changes propagate because your custom domain is still showing two sets of name servers, although now your SquareSpace DNS entries point to your Netlify website, which before they did not.

Okay that makes sense and I think, fingers crossed, the error will be resolved when the changes propagate. I’m not sure why there were two DNS servers to begin with as that was the Squarespace default. I changed to custom servers and only inserted the dns1-4 that Squarespace provided hopefully excluding the NS01-04 that was attached in your original reply. Will wait and see. Thanks again for the help.

@tolks Tucows seems to be taking its sweet time letting everyone else know about your DNS changes, but they are starting to propagate. With any luck, by tomorrow morning the picture will be much clearer.

No problem, will check back tomorrow. Thanks again for the quick responses and all the help. Much appreciated.

Is there any more information or clarity on your backend? I’m still getting the same error when accessing the admin site and the only suggestion I can find is to get organization approval but I don’t have any organizations in my git. Thanks.

@tolks I should clarify I’m just a user like you. I don’t work for Netlify, so I have no access to any backend.

However, it appears that you still have two separate sets of name servers set up for your custom domain.

|===================== dig name server(s) for ===================
| -------------------------- tolks.me --------------------------
| ------------------- should agree with whois -------------------
ns02.squarespacedns.com.
ns03.squarespacedns.com.
ns04.squarespacedns.com.
dns1.p03.nsone.net.
dns2.p03.nsone.net.
dns3.p03.nsone.net.
dns4.p03.nsone.net.
ns01.squarespacedns.com.
|================================================================

Oh damn well I’m even more appreciative of the help then, so thanks again. I don’t understand why that’s till showing. Those are the squarespace default as you can see in the picture but I’ve had it switched to the custom domains of only dns1-4 since yesterday afternoon which are also displayed. Any suggestions as to what to try next?


@tolks If you wish to use Netlify DNS, use the *.nsone.net servers, not the *.squarespacedns.com servers

Check the TTL setting and reduce it to the minimum value until your changes propagate