Home
Support Forums

External custom domain and Netlify DNS

Hi, I got problems with a custom domain, registered with another provider. The site in question is https://fervent-bell-93107f.netlify.app/ and the domains I want to use are www.visit-goteborg.com and visit-goteborg.com.

So far I’ve setup the name servers found in (Team → Domains → Name servers in Netlify) with the domain provider. They seem to point right when i lookup the domain. When I curl the domains I get the expected result.

% curl -sI https://www.visit-goteborg.com
HTTP/2 200
cache-control: public, max-age=0, must-revalidate
content-length: 298
content-type: text/html; charset=UTF-8
date: Tue, 17 Aug 2021 16:11:29 GMT
etag: "3feed6e9ebbe04dee03f7dfdbe761085-ssl"
strict-transport-security: max-age=31536000
x-nf-request-id: 01FDAE3K5T3ZYPKQBW1FYTHHT1
age: 0
server: Netlify

% curl -sI https://visit-goteborg.com
HTTP/2 301
cache-control: public, max-age=0, must-revalidate
content-length: 47
content-type: text/plain
date: Tue, 17 Aug 2021 16:12:09 GMT
strict-transport-security: max-age=31536000
x-nf-request-id: 01FDAE4TH50PN0RHB7XRKANHGE
age: 0
location: https://www.visit-goteborg.com/
server: Netlify

And for the Netlify subdomain curl call looks like

% curl -sI https://fervent-bell-93107f.netlify.app
HTTP/2 200
cache-control: public, max-age=0, must-revalidate
content-length: 298
content-type: text/html; charset=UTF-8
date: Tue, 17 Aug 2021 16:13:42 GMT
etag: "3feed6e9ebbe04dee03f7dfdbe761085-ssl"
strict-transport-security: max-age=31536000; includeSubDomains; preload
x-nf-request-id: 01FDAE7NEC8X03VW9V9J4TTSNJ
age: 0
server: Netlify

In the Domain management section Netlify puts the Netlify DNS label on my domains and there are no errors from when I created the HTTPS certification with Let’s Encrypt.

Still the website wont show up on any of the domains :thinking: When I type the subdomain https://fervent-bell-93107f.netlify.app/ it redirects to Velkommen til Gøteborg — Goteborg.com which is right.

I’m using Hugo static site generator and these are my configs

netlify.toml

[build]
  command = "npm run build:site"
  publish = "public"

[build.environment]
  HUGO_VERSION = "0.82.1"

[[redirects]]
  from = "/dk/*"
  to = "/dk/404.html"
  status = 404

[[redirects]]
  from = "/no/*"
  to = "/no/404.html"
  status = 404

config.toml (hugo)

baseurl = "https://www.visit-goteborg.com/"
defaultContentLanguage = "dk"
defaultContentLanguageInSubdir = true

.... removed unrelated hugo stuff to make this shorter.

I’ve read through the support guides on Netlify and in this forum but I can’t really get what I’m doing wrong. Please help :slight_smile:

hi there, i just tried to access https://www.visit-goteborg.com/ and i was redirected to https://www.visit-goteborg.com/dk is this correct?

1 Like

Looks perfekt, do you get the redirection from https://visit-goteborg.comVelkommen til Gøteborg — Goteborg.com as well? I still can’t see it. But I guess I have to wait even longer for changes to propogate (36ish hours by now).

Hey @primalivet

I see the same thing as @perry; including a working redirect.

If you are still not seeing this, have you tried a private/incognito window, a different browser, device, and/or network? Local caching can often mess things up.

Thanks for the reply @coelmay, yeah I’ve tried all of what you suggested. However, now i switched to another network (that assigns me a different DNS) and i seem to work. So I guess my primary network DNS is just really slow to update changes :slight_smile:

Again big thanks @coelmay and @perry