Exit Code 128 - Permissions Issue

Having an issue deploying a build due to not being able to read remote Github repository.
Have deployed this same site from same repository countless times and now having an issue.
Reconfigured the Netlify GitHub app and re-linked the repository to the site, should be no issues with permissions yet still getting this error.

Thanks in advance.

Site id: 05c5142f-d5e1-4d3d-a2b3-708c06029f38
Domain: https://shade-redemption.netlify.app

Hi @znasgo

I noticed that you were able to build the site a few hours after your initial post.

Have you been able to sort it out? What was the issue at the end?

Hope to hear from you!

Yes figured it out, thanks for your response!
I had downloaded an npm package after the previous build and for some reason when I was trying to build it was having a permission issue related to one of those new dependencies. Uninstalled them and tried to build again and it worked fine.

Great! Glad this is all sorted out.

If you need anything else let us know!

I’m facing a similar problem. Currently, I’m working on a WEB3 crowdfunding application. My contracts are deployed on Thirdweb and I’m trying to deploy the frontend on netlify. But when I try to deploy it using the GitHub repository it gives me Exit code 128 - permissions issue. But when I drag and drop the build folder my website is deployed and working correctly.

Link to GitHub repo - GitHub - LEGO-SUDO/WEB3CROWDFUNDING

hi @lego

I forked that public repo and also got stuck with the same error:

I haven’t checked the repo yet but probably you’re trying to access a dependency, in that case you’ll have to probably use a access token and pass that on to Netlify as an environment variable that we can use.

It works on drag-and-drop because on that flow you’re sending us the resulting public assets so we only serve, we don’t build.

Hope that helps!

Can you share a resource on how to do that? I have never done this before.

Hi @lego :wave:t6: ,

Sorry, what resource are you referring to? Drag and drop if so here is a link.

You can execute it here.

I was asking for a resource on how to provide access tokens for the dependencies. As told by Gualter.
Even when I deployed the website using drag and drop and whenever I refresh the website it gives me a page not found error. I have setup my netlify.toml file as I do with any other deploy and there I don’t face any issues but I’m facing issues here.

Link to the website - https://exquisite-ganache-20dd4c.netlify.app/

My netlify.toml file

from ="/*"
to = "/index.html"
status = 200

I also get this error when deploying:

Have also try dragNdrop but got a 404…

Hi can you share your slug please?