Errors during site build

Hi, I’m a newbie to netlify and webdev things in general. We had a deployment that worked a month ago and now doesn’t. I’ve tried doing “CI= npm run prod” and tried setting an environment variable to ‘’, ’ ', false or just an empty space and my build doesn’t succeed.
The end of my error log is below (couldn’t fit most of it because of character and ‘link’ limits). Ostensibly it’s not related to netlify, but nothing else has changed in the configuration. Could someone please shed some light on this?

3:59:44 PM: …/…/nan/nan.h:2370:3: warning: ‘bool v8::Object::Set(v8::Localv8::Value, v8::Localv8::Value)’ is deprecated: Use maybe version [-Wdeprecated-declarations]
3:59:44 PM: recv->Set(name, GetFunction(tpl).ToLocalChecked());
3:59:44 PM: ^
3:59:44 PM: In file included from /opt/buildhome/.node-gyp/12.18.0/include/node/v8-internal.h:14:0,
3:59:44 PM: from /opt/buildhome/.node-gyp/12.18.0/include/node/v8.h:27,
3:59:44 PM: from /opt/buildhome/.node-gyp/12.18.0/include/node/node.h:67,
3:59:44 PM: from …/…/nan/nan.h:52,
3:59:44 PM: from …/src/binding.cpp:1:
3:59:44 PM: /opt/buildhome/.node-gyp/12.18.0/include/node/v8.h:3499:22: note: declared here
3:59:44 PM: bool Set(Local key, Local value));
3:59:44 PM: ^
3:59:44 PM: /opt/buildhome/.node-gyp/12.18.0/include/node/v8config.h:328:3: note: in definition of macro ‘V8_DEPRECATED’
3:59:44 PM: declarator attribute((deprecated(message)))
3:59:44 PM: ^
3:59:44 PM: recipe for target ‘Release/’ failed
3:59:44 PM: make: *** [Release/] Error 1
3:59:44 PM: make: Leaving directory ‘/opt/build/repo/node_modules/node-sass/build’
3:59:44 PM: gyp ERR! build error
3:59:44 PM: gyp ERR! stack Error: make failed with exit code: 2
3:59:44 PM: gyp ERR! stack at ChildProcess.onExit (/opt/build/repo/node_modules/node-gyp/lib/build.js:262:23)
3:59:44 PM: gyp ERR! stack at ChildProcess.emit (events.js:315:20)
3:59:44 PM: gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:275:12)
3:59:44 PM: gyp ERR! System Linux 4.14.138+
3:59:44 PM: gyp ERR! command “/opt/buildhome/.nvm/versions/node/v12.18.0/bin/node” “/opt/build/repo/node_modules/node-gyp/bin/node-gyp.js” “rebuild” “–verbose” “–libsass_ext=” “–libsass_cflags=” “–libsass_ldflags=” “–libsass_library=”
3:59:44 PM: gyp ERR! cwd /opt/build/repo/node_modules/node-sass
3:59:44 PM: gyp ERR! node -v v12.18.0
3:59:44 PM: gyp ERR! node-gyp -v v3.8.0
3:59:44 PM: gyp ERR! not ok
3:59:44 PM: Build failed with error code: 1
3:59:46 PM: npm WARN climdex-site@1.0.0 No repository field.
3:59:46 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.11 (node_modules/fsevents):
3:59:46 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.11: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
3:59:46 PM: npm ERR! code ELIFECYCLE
3:59:46 PM: npm ERR! errno 1
3:59:46 PM: npm ERR! node-sass@4.9.3 postinstall: node scripts/build.js
3:59:46 PM: npm ERR! Exit status 1
3:59:46 PM: npm ERR!
3:59:46 PM: npm ERR! Failed at the node-sass@4.9.3 postinstall script.
3:59:46 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
3:59:46 PM: npm ERR! A complete log of this run can be found in:
3:59:46 PM: npm ERR! /opt/buildhome/.npm/_logs/2020-07-20T05_59_46_185Z-debug.log
3:59:46 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1
3:59:46 PM: Error during NPM install
3:59:46 PM: Error running command: Build script returned non-zero exit code: 1
3:59:46 PM: Failing build: Failed to build site
3:59:46 PM: Finished processing build request in 2m21.559997771s

Hi, @nick2. I moved this post to its own topic as this doesn’t appear to be related to the CI setting.

It would help us to answer if we could review the full build logs. Would you please send us a link to the deploy?

For example, a link similar to the one below:

Once we examine the complete log we’ll be able to better research this and, hopefully, find a solution for this build issue.

Hi @luke, thanks very much. I guess I shouldn’t assume my problem is related to the “CI =” change. Sure, the link is

Again, the repo hasn’t changed since the last time it was successfully built.

Hey Nick,

I think that this is, in fact, your error:

7:32:40 AM: Downloading binary from
7:32:40 AM: Cannot download "":
7:32:40 AM: HTTP error 404 Not Found
7:32:40 AM: Hint: If is not accessible in your location
7:32:40 AM:       try setting a proxy via HTTP_PROXY, e.g.
7:32:40 AM:       export HTTP_PROXY=
7:32:40 AM: or configure npm proxy via
7:32:40 AM:       npm config set proxy

@Pie, oh jeez, thank you for pointing that out. I had assumed since nothing changed on our end it was the new change to building that Netlify recently implemented. I didn’t see that error. Great!

1 Like